Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

No email recieved using Scriptrunner

Hi,

I have added the following script to a workflow transition in JIRA. When I run the preview the email looks fine, and when I do the transition of the issue the script looks like every thing wnet OK, but I do not receive the email. Does anyone know what to do?Scriptrunner_email.JPGScriptOK.JPG

 

 

1 answer

1 accepted

1 vote
Answer accepted

When the mail is triggered, check the mail queue to see if it appears soon after. If you see it appear there, and definitely isn't obscured by a spam folder/mail rule, there could be some other problems. Make sure there is no space after the email address. In old versions of SR, I found that if I did not properly separate email cc/to's that emails could fail.

Hi, I checked the mail queue, and the mail does not appear there at all. I have no Space after the email adress.

JIRA version: 7.2.8

SR Version: 5.2.1

Ah ok. I think this is the problem. Change your logic in the condition to:

cfValues['field name']?.getValue() == 'Yes'

If it's a select list (assuming this), it needs the getValue method. 

Hi, thanks for Your quick reply, but I still do not recive an email. When I change th Logic into Your code.. I get a warning saying "Could not look up the type for this custom Field.."

Okay, try just

cfValues['field name']?.value == 'Yes'

Thanks, but thats what I tried the first time, if you see my  screen shot..?

On the screenshot you don't include the ?.value portion.

 

Also, is the field just a simple Single Select? what sort of field type is it?

Thanks - now it Works fine:-)

Terrific. Please mark this answer as accepted using the checkmark button.

@Kyle Moseley I am having the same issue, but my email is showing up in the mail queue. I cannot see what the error is. I left my condition and configuration field blank.  But, the rest of my settings are identical to hers. I'm sending to an email address as string in a custom field.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

Staying organized with Jira: best practices for a better project management

Project managers know this problem: A “mountain of work” lays in front of you, and you don’t know how and where to tackle them. Different to-dos lie ahead, but just one task after the other can be ha...

232 views 2 1
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you