Behavior plugin is showing attachment with asterisk when set Affected version as required

Hello,

I am using Behavior plugin to show affected version and a custom field to show required. However affected version is not showing asterisk instead showing on attachment, but attachment is not required field.

below is my configuration

<config use-validator-plugin="false" name=" Defect mandatory fields" description="" guideWorkflow="null">
<field id="versions" required="true" readonly="null" hidden="null"/>
<field id="customfield_17780" required="true" readonly="null" hidden="null"/>
<init id="__init__"/>
</config>

 

Need help to understand how to set it correctly.

I am using JIRA 7.2.8 & behaviour from the script runner Version:4.3.15

1 answer

1 accepted

0 vote
Joshua Yamdogo Community Champion Dec 07, 2017

Hi Rahsmi,

This sounds like the bug reported here: https://productsupport.adaptavist.com/browse/SRJIRA-2200

Because of the bug, the red asterisk appears next to the Attachments field instead of the custom field that it is supposed to be next to.

This bug was fixed in SR 5.0.11.

Suggest an answer

Log in or Join to answer
Community showcase
Emilee Spencer
Published yesterday in Marketplace Apps

Marketplace Spotlight: DeepAffects

Hello Atlassian Community! My name is Emilee, and I’m a Product Marketing Manager for the Marketplace team. Starting with this post, I'm kicking off a monthly series of Spotlights to highlight Ma...

47 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot