We have encountered a tricky issue that calls for a feature unless someone can help with a workaround:
We have a custom mail handler on a software project that processes emails from external customers. We are using a default reporter in the mail handler.
This works fine unless the customer reporting the issue through this email is also a customer in one of our service desk projects. This will now fail as the customer already is a user and this user does not have a Jira software license with this message:
"Cannot create issue due to invalid license: [Sorry, you can't create any issues right now, as you need to have access to a Jira application to be able to create issues. To gain application access you need to be a member of a group assigned to an application.]"
Is there a way to tell the mail handler to fall back on the default reporter if the reporter does not have a license?