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Upgrading Confluence from 5.6.6 WAR to 6.5

Norbert Hermann March 22, 2018

Hello,

I've trouble with upgrading Confluence from 5.6.6 WAR to 6.5

The Change from WAR to Standalone was successfull, but now I'm really facing a problem.

- all incompatible or unknown plugins were disabled
- the collation of the database was checked
- max_allowed_package is 256M

Has anybody here got any ideas?

###

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A system error has occurred — our apologies!

For immediate troubleshooting, consult our knowledge base for a solution.

If you would like to receive support from Atlassian's support team, ask your Confluence administrator to create a support issue on Atlassian's support system with the following information:

    a description of your problem and what you were doing at the time it occurred
    a copy of the error and system information found below
    a copy of the application logs (if possible).

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Cause

java.lang.reflect.UndeclaredThrowableException
    at com.sun.proxy.$Proxy79.permissionExists(Unknown Source)

caused by: java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

caused by: org.springframework.dao.InvalidDataAccessResourceUsageException: could not extract ResultSet; SQL [n/a]; nested exception is org.hibernate.exception.SQLGrammarException: could not extract ResultSet
    at org.springframework.orm.hibernate5.SessionFactoryUtils.convertHibernateAccessException(SessionFactoryUtils.java:224)

caused by: org.hibernate.exception.SQLGrammarException: could not extract ResultSet
    at org.hibernate.exception.internal.SQLExceptionTypeDelegate.convert(SQLExceptionTypeDelegate.java:63)

caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Unknown column 'spacepermi0_.PERMALLUSERSSUBJECT' in 'field list'
    at sun.reflect.GeneratedConstructorAccessor278.newInstance(Unknown Source)
Stack Trace:[hide]


1 answer

0 votes
Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 23, 2018

Norbert,

Seems there may be a problem with your database. Can you let us know your database and version, and confirm your collation there?

Regards,

Shannon

Norbert Hermann March 23, 2018

Hi Shannon,

the database is mysql 5.5.59
charset utf8 collation utf8_bin

Thanks

Norbert

Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 23, 2018

Norbert,

Thank you for your confirmation. Since MySQL 5.5* isn't supported in Confluence 6.5, I would recommend moving to MySQL 5.6 or higher.

  1. Create a supported MySQL Database using these instructions.
  2. Migrate your data from the 5.5* database to the new database.

Once you've completed this, if you're still having problems, please let me know.

Regards,

Shannon

Norbert Hermann March 23, 2018

Oh, okay, this is currently a problem in our environment.
Is it possible to migrate the database to PostgreSQL?

Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 23, 2018

Norbert,

Yes, that's possible too.

  1. First, it must be one of the versions here:
    1. (tick) PostgreSQL 9.2
    2. (tick) PostgreSQL 9.3
    3. (tick) PostgreSQL 9.4
    4. (tick) PostgreSQL 9.5
    5. (tick) PostgreSQL 9.6
  2. You can setup the database using this procedure: Database setup for PostgreSQL 
  3. Then, migrate your data using the same procedure from earlier: Migrating to another database

Let me know if you run into any issues.

Shannon

Norbert Hermann March 26, 2018

Hi Shannon

I get an internal server error when I start the backup.

What can I do?

Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 26, 2018

Norbert,

We would need to see the actual error, but you can follow this article to troubleshoot XML backup errors:

Once you've gone through that article if you're still having issues please let us know the full error message you are seeing.

Regards,

Shannon

Norbert Hermann March 28, 2018

Hi Shannon,

the backup was successfully completed in the background.

Now I'm facing the next problem. The restore process only runs up to 4% of completion.
The estimated time is rising steadily, currently it is over 16 hours.

Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 28, 2018

Hi Norbert,

We will still need to know what error logs are occurring, so have a look at the Confluence server logs to see what that might be.

I would still recommend reviewing the article I sent you earlier since it also deals with imports, but have a look as well here:

Can you also let me know how large the backup is?

Shannon

Norbert Hermann March 28, 2018

it's trouble with the java heap space.
How can I change the heap space during installation?
The backup file is about 10 GB in size

Shannon S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
March 28, 2018

Hi Norbert,

You can increase memory following this documentation:

Have a look there and let us know if you have any trouble.

Regards,

Shannon

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