The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

The page could not to be previewed or closed, if it has "../" symbols

ArtemMo
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 25, 2023

In Confluence 7.19.17 we have found a bug.

When we edit a page with body, that has symbols

"../", the page could not to be previewed or closed.

So we have a 400 error response when we pressed button “Preview” or “Close”.

 

 

 

>>> Request

POST /pages/rendercontent.action HTTP/1.1

Host: confluence-test.hidden.domain

User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:120.0) Gecko/20100101 Firefox/120.0

Accept: */*

Accept-Language: en-US,en;q=0.5

Accept-Encoding: gzip, deflate, br

Content-Type: application/x-www-form-urlencoded; charset=UTF-8

X-Atlassian-Token: no-check

X-Requested-With: XMLHttpRequest

Content-Length: 149

Origin: https://confluence-test.hidden.domain

Connection: keep-alive

Referer: https://confluence-test.hidden.domain/pages/editpage.action?pageId=631996965

Cookie: JSESSIONID=F7F533BCA93FF15DD7FAF1C369C06079; CONFLUENCE_RETURNTOCOOKIE=https://confluence-test.hidden.domain/; DEVICEDETAILS=Mozilla/5.0 (Windows NT 10.0: Win64: x64: rv:120.0) Gecko/20100101 Firefox/120.0||Firefox||Windows OS||PDF Viewer, Chrome PDF Viewer, Chromium PDF Viewer, Microsoft Edge PDF Viewer, WebKit built-in PDF||false||Mozilla||en-US, en||true||East Kazakhstan Time||en-US||true; seraph.confluence=666697729%3A0cc11a89bb3de7c43c2a74195f7b8f35dabdc525; confluence.browse.space.cookie=space-templates

Sec-Fetch-Dest: empty

Sec-Fetch-Mode: cors

Sec-Fetch-Site: same-origin

 

>>> Response

HTTP/1.1 400

Server: nginx

Date: Fri, 22 Dec 2023 17:31:12 GMT

Content-Type: text/html;charset=utf-8

Content-Length: 762

Connection: keep-alive

Cache-Control: no-store

Expires: Thu, 01 Jan 1970 00:00:00 GMT

X-Confluence-Request-Time: 1703266272537

X-Seraph-LoginReason: OK

X-AUSERNAME: hidden_username

Content-Language: en

1 answer

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

0 votes
Michael Kotzem
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 2, 2024

Hi, we're facing this issue in 8.5.4 Data Center, too.

 

Regards,

Mike

DEPLOYMENT TYPE
SERVER
TAGS
AUG Leaders

Atlassian Community Events