Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Trello for Gmail Undefined Error when Signing In

Bailly Jamroz December 28, 2022

Hi there,

 

I have a user trying to utilize our trello for gmail integration but when she signs in, the browser replies with an undefined error. We have tried multiple browsers, incognito modes, clearing cache, multiple computers with no luck. 

 

Has anyone run into this issue before and have a solution for it? 

Screen Shot 2022-12-28 at 3.20.06 PM.png

5 answers

1 accepted

4 votes
Answer accepted
John Kotarski
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 24, 2023

I just retried the authorization process again this morning and it worked! I have 2FA enabled on a Google for Education account. I encourage anyone who has had trouble to try again. I didn't do anything differently than I did the first hundred times I tried connecting Trello and Gmail. This time, it just worked as expected. I hope it does for other frustrated Trello users, too!

Alex Knibb
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 27, 2023

Thanks so much for the heads-up, John. Worked for me too!

Devs - worth noting we're using Google For Education too, so I wonder if that's where the issue was?

Sam Ayres February 27, 2023

Same! I'm good now. Thanks!

Marie Quesnel
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 27, 2023

You made my day John!! it works for me now. 

I am not using Google for Education and had the problem... 

0 votes
Richard Hibbert
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 16, 2023

Please can this be fixed or a timescale provided Atlassian? What workaround should we try?

 

I am using google (with 2FA) on a mac. Tried chrome and safari.

 

Would trying other browsers help?

0 votes
Maru Almeida
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 15, 2023

I have the same problem!! very frustrating :(

Screen Shot 2023-02-15 at 11.46.01 AM.png

0 votes
Noelia Sanchez
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 18, 2023

Y have the same problem, Cant it be because of google's two factor identification?

Cody C.
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
January 18, 2023

Hmm, that's a good thought! I just tried adding two factor identification to a test account. I used the "Google prompt" 2FA method. After enabling that option, I tried authorizing the Trello for Gmail Add-on, and it worked as expected for me.

If you have 2FA enabled, could I trouble you to try testing with 2FA turned off? If it works when it's off, but not when it's on, could you let me know which 2FA method you're using?

Like Sam Ayres likes this
Noelia Sanchez
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 19, 2023

I alrady did the test with the computer , when the google prompt is connected it does not work and when you disconnect it it works. The computer tecnician, he said me that`s the problem, because when put on the 2 check verification google stooped working.

For all my colleagues who used it.

0 votes
Vishaal S
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
December 29, 2022

HI Baily,

Vishaal here with Trello—thanks for reaching out

I can confirm that there's an ongoing bug that our Engineering team are investigating where some users can't get past the authentication screen. I've linked your issue to the bug report to inform them that you're also running into this. Once a fix is ready they'll push it out.

For now, I would suggest looking at the email-to-board feature mentioned above as a workaround for creating cards via email.

Leslie Strovas
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 31, 2023

Any update on this bug Vishaal?

Zach Morgan
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 2, 2023

I'm also running into this same issue.

Ryan Magill
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 9, 2023

+1: also experiencing

John Kotarski
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 9, 2023

+1: also experiencing

Sam Ayres February 9, 2023

Also having this problem...Any updates?

Sal
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 9, 2023

Hey everyone,

Sorry for leaving y'all on the lurch here. Our engineering team is still working on this issue to solve it as soon as possible. 

We don't have an ETA for when a fix will be released but rest assured that as soon as there's one available, we will release it. 

In the meantime, as my colleague Vishaal mentioned, I recommend you pivot the usage of the email-to-board feature to create your cards via email as a workaround. 

Thank you!

Like Sam Ayres likes this
Marion Marincat
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 12, 2023

same here

Centro Stampa Cartocontabile
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 13, 2023

same problem

windows 11    norton  360 antivirus      google crome

 

on linux with firefox problem solved

Marie Quesnel
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 13, 2023

same here!

Alex Knibb
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 14, 2023

Same here. Worth noting no-one on my team has this issue, just me. We're all using Chrome on Windows 10 Education. We have Authenticator enabled as we use G Suite internally for most things, if that's relevant. 

Csaba Balla February 23, 2023

Can someone please give us an update ASAP? This issue is still exists, and it has a major effect on some of our work procedures.

Like Alex Knibb likes this
heewon shin
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 27, 2023

same here!

Freddie Blicher
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 31, 2024

This is still in issue in 2024 - over 1 year after the original poster's message. Any update?

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events