Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Dashcards not presenting the list of cards that meet the criteria

Dashcards still work on my boards to present the number of cards found that meet the criteria.  However, the Dashcard list does not appear on the card.  Also, the Track button that comes with the power-up has disappeared, so no new ones can be added.

I've tried different browsers, different boards, and disabling and the re adding the Dashcard power-up, all to no avail.

Any ideas?


2 answers

0 votes
Alina Kurishko
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Feb 28, 2023

Hi Iain and Matt, 

Thank you for raising this topic! It does look like a bug because we were able to reproduce this issue.

Seems like there's also another issue related to the Power-Up that we're looking into. The team is working on a fix, but sadly we don't yet have any ETA to share. 

Sorry about that! 

Alina | The Trello team

Alina, thanks for the response.  The next day things had automagically returned to normal and all working well.  So whatever was done fixed my issue. 

Not having done this before, I am not sure where, as Matt says, I should have reported it as an incident, or was this the right forum?

Also it was only when I didn't have the dashcards working that I realised how much I rely on them!


Alina Kurishko
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Mar 02, 2023

No worries, Iain!

There was a bug that impacted many users, and our engineers jumped right onto it to fix the issue. 

And you're right; it was fixed within a day. 

I you encounter any similar issues in the future, you're free to post a Community question to see if other users experience the same problem.

There's also quite an extensive library of Trello documentation articles with various topics on troubleshooting issues. 

Otherwise, you can contact us directly by filing a ticket at

We're always glad to work on issues together! 

If you have any other questions, go for it! 

Alina | The Trello team

I'm having the same issue.

Not sure what we do with something like this. Do we report it as an incident? Feels like it might be connected to the issue that has just been "solved"

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events