Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

"This is not a valid source path / URL" when cloning SVN?

Hi there!

Ive been using SourceTree for some time and I was satisfied. However, now I receive following warning/error when I try to clone my SVN repository:

"This is not a valid source path / URL"

In details is following info:

user:password:user:password:user:password:abort: 'http://xyz' does not appear to be an hg repository:

---<--- (text/html; charset=UTF-8)

some html markup is here



http authorization required

realm: XYZ Subversion Repository

http authorization required

realm: XYZ Subversion Repository

http authorization required

realm: XYZ Subversion Repository

fatal: http://XYZ/info/refs not found: did you run git update-server-info on the server?

I am running latest version 1.5.3 on Mac OS X 10.8.2.

I tried to clone the SVN repository with another client (Versions) and it was successful.

Can you provide some solution to this problem?


1 answer

1 accepted

0 votes
Answer accepted
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Sep 26, 2012

Because SourceTree is primarily a Git and Mercurial client, it doesn't include its own copy of Subversion for inter-operating with legacy Subversion servers like Versions does. Unfortunately in Mountain Lion, Apple removed the in-built version of Subversion that used to be included with OS X, only including Git instead.

Here's how you resolve it:


It works now!

I have the same error, except it does it for some of my SVN repos, but others work just fine. All repos are hosted on Assembla.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events