It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

macOS Catalina - Terminal Button Always Opens in Home Folder

I just setup a new computer with macOS Catalina Version 10.15.1

I am running Sourcetree Version 4.0(232)

When I click the Terminal button on the top right, it always opens the terminal in my home folder and NOT the repository working directory.

I thought it was just a bug with the newer version of SourceTree, but I upgraded my old computer to Catalina and the same version of SourceTree, and my old computer opens the terminal in the correct repository directory.  I notice that somehow a cd command takes place immediately after the terminal is launched, but my new computer won't do that.

I have compared settings between the two computers, searched everywhere I can find, and I cannot figure out how to get Sourcetree to change directory in the terminal on my new computer.

It's pretty inconvenient to have to cd manually every time I open a terminal window.  Help!

 

Thanks,

Steve

10 answers

1 accepted

18 votes
Answer accepted

This worked for me:

  1. Uninstall current version.
  2. Install old version (3.2.1) from https://www.sourcetreeapp.com/download-archives
  3. Press the terminal button and it will ask for folder permissions.
  4. After giving the permission, uninstall the old version and install the the latest version again.

Thank you, Mike.

Like douglaskazumi likes this

Thanks a lot !

Like Steve King likes this

Thanks a lot. This worked for me. Only took about 2 minutes.

  1. Downloaded version 3.2.1
  2. Extracted and moved the sourcetree.app file to the applications folder and replaced the current one.
  3. Opened SourceTree
  4. Clicked the terminal icon, it will prompt for permissions. Allow it. ;)
  5. Checked for, and updated to 4.0
  6. Relaunched.
Like # people like this

Thanks a lot. But it's not worked for me. :(
I downgraded to version 3.2.1 and clicked the terminal icon, but it did not prompt for permissions.

Now install the newer version. It should work after that. 

Thank you, Mike! Your solution with temporary downgrade really works!

Like Steve King likes this

The following steps worked on my Mac.

  1. Uninstalled SourceTree 3.2.1
  2. Installed SourceTree 2.7.1
  3. Installed iTerm2 Build 3.3.9 (the latest version in Homebrew)
  4. Clicked the terminal icon, then the permission dialog was displayed.
  5. Upgraded to SourceTree 4.0.1

Thanks.

The following steps worked on my Mac.

  1. Uninstalled SourceTree 3.2.1
  2. Installed SourceTree 2.7.1 (159)
  3. Installed iTerm2 Build 3.3.9 (the latest version in Homebrew)
  4. Clicked on the terminal icon, then the permission dialog was displayed.
  5. After giving the permission, upgraded to SourceTree 4.0.1 (234).

Thanks.

It worked, thanks!

You don't need to uninstall and reinstall the latest version, just download and extract and run the 3.2.1 version in the downloaded folder and click Terminal and accept permissions, then just delete the 3.2.1 version and continue with the latest as usual.

Like Steve King likes this

Same issue for me, to make it work I had installed sourcetree older version

I'll have to try that.  Thank you!

I agree with  Nguyen, is there an actual fix yet from Atlassian?

  1. Open macOS's System Preference
  2. Security & Privacy
  3. Privacy tab
  4. Automation in the left pane
  5. Check SourceTree.app's Terminal

I had already solved this a while back, but this looks like it might have worked!

Sourcetree isnt present there unless youve already accepted permissions in pre 4.0 version. Follow accepted answer instead.

Like Steve King likes this

Same thing happens to me (same macOS ad SourceTree versions), also, open in terminal is no longer opening a new terminal window when the Terminal is already open.

Same here with not opening a new window when Terminal already open.

Any answer?  A solution anybody??

Same thing happens to me on Catalina and my new computer. Doesn't happen on old computer on Catalina. 

Well it's nice to know I'm not alone, but anybody have any ideas?  Is there a way to get support?  Does someone knowledgable at Atlassian ever check these boards?

Same issue here

Same issue. I don't want to reinstall the older version.

It's just a temporary measure.  As soon as you install the older version, upgrade to the latest.

Like llinardos likes this

You dont have to uninstall and reinstall/upgrade to latest again, just download and extract 3.2.1 and run it in whatever folder you downloaded it to and click terminal button and delete the 3.2.1 version and continue using the latest.

Like Steve King likes this

Worked for me - had the same trouble after I updated to catalina last night

Installed older version 3.x

Ran the open terminal from sourcetree

gave the permission

close source tree

downloaded the latest version

installed it

Mac blocked the latest version as un trusted.

Gave the permission via security and privacy setting

worked fine

Thanks to all those who contributed here to help.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,927 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you