SourceTree takes 3 seconds to stage/unstage a file

Staging or unstaging a file takes almost 3 seconds. This is on a top-end late-2013 Macbook Pro.

It doesn't make a difference if it's done from the menu or by double-clicking.

It's the same whether it's adding a new file, or staging changes to an existing file. Even a few lines changed in a modestly-sized file (few hundred lines) exhibits this.

I do not have any untracked files.

I tried changing the view filter from "Show Pending" to "Show Modified" and that didn't help either; if anything it made it worse (5 seconds!).

How can I improve this?

SourceTree 1.8.1, using embedded Git.

Macbook Pro, OS X 10.9.1, 2.6GHz Core i7, 16GB RAM

11 answers

How long does git stash on the shell need? At least on Windows SourceTree only invokes shell commands.

git add or git stash on the command line are both instantaneous. This delay is definitely coming from Sourcetree rather than Git. To further describe what I see:

A dialog pops up saying "Staging files". This disappears after about half a second.

Two little round spinning progress indicators pop up; one in the working tree, and one in the index. These spin round for 2 or 3 seconds.

The file in question finally disappears from the working tree and reappears in the index area. After the file has appeared in the index, the two little spinners start spinning again for another second or two.

Once the spinners stop for the second time, then Sourcetree settles down and I can continue working. The overall process is at least 3 seconds.

You mentioned you have no untracked files, and you are staging relatively small changes. What about your repository itself? How big is it?

Total size = 32M

.git = 1.6M

Size of tracked files = 5M

(Ignored files 27M approx)

Total number of files (including .git) = 614

Not very big, then. The only other good reason I can think of would be if your repository wasn't on a local, internal drive. I would expect a little lag or slowness from a flash drive or network storage.

Right. It's all local, on the internal SSD. And as I mentioned, the equivalent git commands in the shell execute instantaneously.

An SSD even. I can't think of any good reason for SourceTree to take that long. Hopefully you get some attention from Atlassian on this.

Years go by they are still not bating an eye. Great company, if only i had simple alternative i would abandon this trashware this instant.

also this - https://www.plasticscm.com will give it a shot, friend suggested

http://www.npackd.org/p/com.sourcetreeapp.SourceTree/1.5.2 ive read people recommending to use this old version, im trying it now, it may fix problems introduced by unable coders in latest versions.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

430 views 0 1
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you