It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

SourceTree remote repository settings not saving again

Hi.  Something similar happened in a previous version where changing remote settings wouldn't save, but it was eventually fixed.  Now in the most recent update, what it won't save is Optional Extended Integration Remote Account.  It keeps defaulting back to Generic Account once a day instead of keeping jraymond-gr Bitbucket selected.  I guess I could just roll back to the previous version if I can find an installer, but maybe this will just draw Atlassian's attention to the problem?  Or maybe someone has a fix?  Thanks!

- joe -

9 answers

This is happening to me too

Denis_Kot I'm New Here Feb 17, 2020

+1

If this is happening to you, make sure you go to the bug report for it and comment/like/watch: https://jira.atlassian.com/browse/SRCTREEWIN-12912

Hmm, looks like there are 7 or 8 bugs on this, all marked as "Needs Triage", even ones that are 4 months old. Are they really just ignoring all bug reports?

Yes, they ignore them. Even for the paid products.

Their "New improved navigation", that actually is the same as it was years ago, is obviously so much more important.

+1 same here on windows 10 and v 3.3.8.3848

Happening to me too, i am on version 3.3.8, the current last version

Same here.  Version 3.3.8 on Windows 10.  It forgets after the app is restarted.  As long as the app keeps running, it remembers; even if you close a repo tab and then re-open it.

Like # people like this

Happening to me also. There are some workarounds but all seem to be temporary. I think Atlassian may be aware of the issue as it's been widely reported but have not taken any action to resolve it yet.

Same thing happens to me. may 2020 and still not fixed

Still happeing to me at least last two version... buggy software... march 2020

I'm glad I found this thread. I'm also having the issue. Not sure exactly which tracking ticket to note it on, so I just updated the one higher up in this thread. (https://jira.atlassian.com/browse/SRCTREEWIN-12912?_ga=2.20029566.772437837.1589823722-1091461189.1549929168)

I went to the download archives and got 3.3.6 for Windows. It doesn't seem to have the Optional Extended Integration credential saving problem. (Download archive: https://www.sourcetreeapp.com/download-archives)

Hope that helps someone else. I beat my head against this for a day before thinking to do this search. >_<

Thanks!  Yeah, that DOES fix it.  Nice find.

Weird, I was having this problem on 3.3.6, and upgraded to 3.3.8 in hope it would solve the issue.

:(  I'm usually the one that fixes don't work for.  It feels nice to have something work in my favor for once.

I am also on 3.3.6 and have the issue. I upgraded to 3.3.8 and still had it, and downgraded to 3.3.4 and still had it.

I found a fix that works on 3.3.6, and will probably also work on 3.3.8.

While poking around I found the log file, and saw an exception failing to load a TimeZoneConverter library that it couldn't find. I went to https://www.nuget.org/packages/TimeZoneConverter/2.3.0 and downloaded the package. It is just a zip file so I extracted timezoneconverter.2.3.0.nupkg\lib\netstandard2.0\TimeZoneConverter.dll and put it into %AppData%\Local\Atlassian\SourceTree\hg_extras, and now it doesn't reset to Generic Account any more! Yay!

1 vote
Nassel I'm New Here Jun 11, 2020

I'm not sure if it's the right solution, but I've found a way to solve this phenomenon and will share it.
I've been suffering from this phenomenon since the upgrade to Soucetree 3.3.4, and even after upgrading to 3.3.8, I haven't been able to solve it and am in trouble.
However, by re-installing Sourceetree and re-registering the bookmark of the repository in the next step, this phenomenon was released.
However, the reinstalled version is 3.3.6 for Windows.

■ Procedure (Windows 10)
1. Uninstall Source Tree from Apps and Features
For Windows 7, it is "Programs and Features" in the Control Panel.

2. Delete the "Atlassian" and "Soucetree" folders from the following folders (when the OS drive letter is C)
・C: / users / <user name> / AppData / Local
・C: / users / <user name> / AppData / Roaming

3. Install any version of Sourceetree

■Notes on work
-The folder location accessed in step 2 is for Windows 10. It may be different on other Windows.
-The folder accessed in step 2 is a hidden folder.
-The folder accessed in step 2 is a very delicate area used by the system and applications. Modifying other than the desired folder may adversely affect the system. Please work carefully.
-If you are using the built-in Git, the version of the built-in Git will be replaced with that of the Sourcetree installer you are installing. If necessary, please update the built-in Git from the "Git" tab in "Options" of the "Tools" menu.


I hope this information helps you.
Thank you.

*I am translating it into English with Google Translate. I am afraid there is something wrong with the text, but please forgive me.

Actually I think it worked. Thanks Nassel! 
I removed v 3.3.8, downloaded 3.3.6 and it seems to work now.

Tomorrow (19 June 2020) I will confirm!

 

UPDATE (18 June 2020)

 v 3.3.6 seems to have another bug. It doesnt refresh the UI after commit, push, merge...

You always have to press F5. I'll try a reboot and see what happens. Restarting the app didn't solve.

Reboot didn't solve, so I downgraded to 3.3.4.
Now it does refresh, but it "forgets" the remote accounts. Incredible. I'll try an older version.
I'm speechless.

 

UPDATE (19 June 2020)

Yesterday after downgrading to 3.3.4 I was notified about the 3.3.9 update, so I ran the update.

So nothing, even 3.3.9 forgets remotes. I'll keep this for now, but at this point I'll consider moving to Fork.

 

FINAL UPDATE (19 June 2020)

I solved all of my issues by uninstalling everything, deleting the folders under %APPDATA% as Nassel suggested and installing v 3.2.6 enterprise.

I'll stick with this for a while ;)

 

Antonino, thanks for the reply.

The UI not updating issue is a serious bug in Sourceetree 3.3.6.
Information about this issue is in a separate thread.
https://community.atlassian.com/t5/Sourcetree-questions/Why-won-t-UI-refresh-after-staging-in-files-in-Sourcetree/qaq-p/1272146

However, this phenomenon does not occur on the current PC.
Is it due to a clean installation? but this is a guess.

Antonino, I read your reply and thought:
1. Summarize the situation that occurred
-Updating from version 3.3.4 or earlier to version 3.3.6 or later results in a bug where remote accounts are not remembered.
-This issue does not occur with a clean installation of 3.3.6.
-It occurs when uninstalling 3.3.6 and installing 3.3.4.
2. Predict the cause
-It occurs when the update function of Sourcetree is used.
-It occurs when you uninstall and then install another version.
→ Is it caused by "Run the installation with the source tree file in /appdata/"?

Two tests are based on this guess.
-Update from problem-free 3.3.6 to latest version
-Clean install the latest version using the method I suggested.

Once the test is complete, report each result.

 

UPDATE 24 Jun. 2020

I was making a mistake. sorry.
A critical bug in 3.3.6, the UI not updating, was actually happening. It seems that I pressed the F5 key to update the display.

■Here is the report of verification results.
We are also conducting verifications other than the above, so we will report it together.

・Updated from 3.3.6 to 3.3.9
Result: Symptoms occurred
I could not use the update function, so I updated it with the installer.
When I started it, the remote button wasn't working anymore.

・Uninstall 3.3.6 and install 3.3.4 as is.
Result: Symptoms occurred
We were able to confirm the reproducibility of the phenomenon that occurred on the Antonino's PC.

・Clean installation of 3.3.4, 3.3.8, 3.3.9
Result: Symptoms occurred
You can use the remote button immediately after installation or immediately after adding a bookmark.
However, when I close SourceTree, the buttons stop working again.

· Clean install 3.3.6 again
Result: Symptoms may occur
I didn't understand. Why do the symptoms come back?
I installed 3.3.6 cleanly 3 to 4 times, but the phenomenon continued to recur.
The next day, I tried a clean installation 3.3.6 again, but the symptom did not occur. Repeating the clean installation 5-6 times a day did not cause any symptoms.

・Clean installation 3.2.6
Result: Works fine

■ What is discovered and what can be inferred from the results
・This issue has occurred since 3.3.4 and has not been improved in the latest version 3.3.9 on June 24, 2020.
・You may not be able to successfully perform a clean installation of 3.3.6.
・In 3.2.6, the phenomenon did not occur in the first place
・3.3.6 is not a solution to any other problem (reproduce bugs such as UI not being updated automatically)

I think the solution in the procedure I wrote works with SourceTree 3.3.6 or 3.2.6 or earlier.
Use 3.3.6 if you can tolerate issues with UI not updating automatically on F5, and use 3.2.6 if you want more stable behavior.

* Translated into English with Google Translate. I think there is a problem with the text, but please forgive me.

Same problem for me, and for a while now...

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,083 views 0 11
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you