Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

SourceTree Mac and Gitlab CE

Is there any possibility to connect ST on Mac with Gitlab CE account?

I tried everything, but no luck

1 answer

Yes, you can. 

1) Go to SourceTree Preferences ->  Accounts
2) Press Add... button
3) Fill all fields BUT in the "Password" field you must to enter personal access token!

Creating a personal access token

You can create as many personal access tokens as you like from your GitLab profile.

  1. Sign in to GitLab.
  2. In the upper-right corner, click your avatar and select Settings.
  3. On the User Settings menu, select Access Tokens.
  4. Choose a name and optional expiry date for the token.
  5. Choose the desired scopes.
  6. Click the Create personal access token button.
  7. Save the personal access token somewhere safe. If you navigate away or refresh your page, and you did not save the token, you must create a new one.


Thanks, but when I give all credentials, still got this:

We couldn't connect to GitLab CE with your (MarekBakalarczuk) credentials. Check your username and try the password again.

Did you create access token in GitLab with all scopes? You must to use it password field. Its look like "W543dfG3zQddsd6kMq29Z"

Yes I did. But it look like  "sd1fafYMPBYQ5za-xfsm"

OK. I did token again and it has proper format. 

But still I cannot make an account. 

Maybe it is username matter? It has to be a Gitlab CE login or profile user name?

Or maybe I need to enable two-factor authentication?

username must be a Gitlab CE login

in my Gitlab i has no two-factor authentication

It is not working either. Thanks anyway.

It was not working for me either. However: After waiting a couple of minutes after creating the access token, I tried again. This time, when I clicked "Save" I pressed it three times in rapid succession (originally, when I clicked it, nothing happened.) Then... it worked.

I'm not sure if rapid clicking made it work or if I just had to wait for GitLab CE to propagate the access token.

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events