SourceTree 1.8.1 for Mac OS X - preferences problem

Hello

The problem is simple :)

In Preferences -> Git -> Push branches

I have default value "matching" and when I change it to "current" it won't save after leaving preferences. In consewuence this setting option just doesn't work.

Thank You for Your patience.

4 answers

1 accepted

Hey there,

This could well be because on the General tab you're not allowing SourceTree to modify you Git/Mercurial configuration. This would stop this option from being changed. There's already an open JIRA issue to disable this drop down if you don't allow SourceTree to modify your global Git config.

Cheers

=D that's made the problem go away. Thank you!

Yes it worked. Thank You !

I'm having this issue as well, it's very irritating having to uncheck all of the boxes. I decided to wait for the update but it looks like it hasn't been fixed. Any help with this issue would be fantastic!

I'm having this issue as well, it's very irritating having to uncheck all of the boxes. I decided to wait for the update but it looks like it hasn't been fixed. Any help with this issue would be fantastic!

Did Kieran's solution of checking the settings in the General tab not work for you?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

992 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you