(SOLVED) Please help Sourcetree Wont accept password for login Edited

Manu Saiz I'm New Here Dec 03, 2018

SOLVED: I WRITE IT HERE AS THIS PAGE WON'T LET ME ANSWER

(error message: "invalid format try plain text" but I went to Notepad and still won't enter, anyway. here's the solution:

SOLUTION

OK GUYS!

This is what after 8 hours and 3 friends less solved the problem:

Navigate to:
AppData > Local > Atlassian > SourceTree

Once there, search and destroy this archive:
passwd.

This allowed me for at least one normal fetch, and push so far. Will update if it fails again.

 

ORIGINAL PROBLEM DESCRIPTION

I keep getting prompted with the Password Window no matter if I enter a right or wrong password. I reseted my password from the atlassian page, nothing works, I tried dozens of suggestions from alegedly succesful solutions for the last 5 hours straight and nothing works, I give up, this makes no sense and I need assistance, please help me.

Under Options > Authentication > Accounts, I have the Atlassian acount where the project is hosted, and the password is set to HTTPS with Authentication "OK".
This password works on the Bitbucket site too.
But when I try to Fetch or Pull, Sourcetree prompts the Bitbucket Login pop up, which doesn't accept any password as correct, and throws this error:

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks -c credential.helper= -c credential.helper="C:/Users/MANUS~1.DES/AppData/Local/ATLASS~1/SOURCE~1/GIT_EX~1/GIT-CR~2.EXE" fetch origin
Logon failed, use ctrl+c to cancel basic credential prompt.
remote: Invalid username or password
fatal: Authentication failed for 'https://manuSaiz@bitbucket.org/manuSaiz/duelcide_scenarios3d_revival_.git/'

Completed with errors, see above.

More details:

I already had Credential thingy v.14, tried updating to v.18, problem persists.

Then I updated GIT.

Problem persists.

Tried changing from embeded to system, problem persists.

Tried updating embeded one, it wont finish updating because problem persists, which also spawns a dozen more login windows.

Also tried reseting all passwords,

updating sourcetree

and even reinstalling sourcetree.

Also tried removing all saved passwords, and guess what?



Yes



Problem persists.

 

Some more details

I managed to perform a pull from the console

But problem persists when performing a regular pull from Sourcetree.

 

Also, maybe this is interesting, I have this problem after using CCleaner (Default options) to recover from some weird FPS lowering condition, which was fixed with the CCLeaning, that may or may not have caused this problem with Sourcetree autenthication.

 

And last but not least, the "SSH pageant" keeps asking for a Key.
This I was used to and I just kept ignoring it, and can't remember a time when it prevented me from pulling, but maybe it is related?

 

Kept trying things, nothing works, help!
- Deleted all the accounts, and added current Bitbucket one (The one where the projects are)

- Created a new SSH key with passphrase, but won't work either, keeps asking for me to start the pageant and Load the key, but if I load it, it throws the very same pop up once and again. Also, the key keeps deleting itself upon PC restart (Which I've been told is normal, but still, what?)


Anyway, please, help.

3 answers

0 votes

Same issue. I wonder if it's related to bitbucket dropping support for TLS1.0/1.1.

0 votes

Same here...

Same here... Sourcetree stopped working yesterday without any changes. Atlassian support only relegates to this forum.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

837 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you