Problems installing SourceTree

hi,

I get the following error when trying to install sourcetree (seel below)

Any help would be appreciated.

Cheers

Tony

PLATFORM VERSION INFO
Windows : 6.1.7601.65536 (Win32NT)
Common Language Runtime : 4.0.30319.17929
System.Deployment.dll : 4.0.30319.17929 built by: FX45RTMREL
clr.dll : 4.0.30319.17929 built by: FX45RTMREL
dfdll.dll : 4.0.30319.17929 built by: FX45RTMREL

SOURCES
Deployment url : http://downloads.atlassian.com/software/sourcetree/windows/SourceTree.application

ERROR
SUMMARY
Below is a summary of the errors, details of these errors are listed later in the log.
* Activation of http://downloads.atlassian.com/software/sourcetree/windows/SourceTree.application resulted in exception. Following failure messages were detected:
+ Lock timeout exception.

COMPONENT STORE TRANSACTION FAILURE SUMMARY
No transaction error was detected.

WARNINGS
There were no warnings during this operation.

OPERATION PROGRESS STATUS
* [3/04/2013 6:41:08 PM] : Activation of http://downloads.atlassian.com/software/sourcetree/windows/SourceTree.application has started.

ERROR DETAILS
Following errors were detected during this operation.
* [3/04/2013 6:43:08 PM] System.Deployment.Application.DeploymentException (LockTimeout)
- Lock timeout exception.
- Source: System.Deployment
- Stack trace:
at System.Deployment.Application.LockedFile.AcquireLock(String path, TimeSpan timeout, Boolean writer)
at System.Deployment.Application.SubscriptionStore..ctor(String deployPath, String tempPath, ComponentStoreType storeType)
at System.Deployment.Application.SubscriptionStore.get_CurrentUser()
at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

1 answer

That sounds like the installer was waiting for a lock on a shared resource, like the ClickOnce install directory or something like that. Did you have anything else running that might have been doing this, like another installer or upgrader?

If you can't track it down I'd recommend trying the installer again just after a reboot.

Yes it turned out to be something to do with my pc and my user rights.

Thanks a million for your help.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

570 views 1 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you