Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,368,487
Community Members
 
Community Events
168
Community Groups

New Source control does not see files

Hi.

I have created a folder called PuzzleGame and inside this is Puzzle which houses my game files. I select PuzzleGame as my sourcetree directory under the new repo options, and Sourcetree creates the .git folder that I can see.

However no changes ever show up. It only ever says "Nothing To Commit".

 

I have tried deleting the .git and starting again, but same outcome. What am I doing wrong?

1 answer

1 accepted

1 vote
Answer accepted
Mike Corsaro Atlassian Team May 15, 2019

Hello! When creating a new repository, please make sure the folder layout looks something like this:

  • My New Repository
    • .git
    • (all the new amazing files you made)

Don't put your files in the .git directory, and be sure to add the "My New Repository" folder to Sourcetree. Hit F5 to refresh the view and you should now see your files.

 

If the above does not work then it would help quite a bit to see the folder structure and screenshots from Sourcetree of the steps you performed. Thanks!

Thanks for the assist but this is how I've set it up and it is still not showing anything. Puzzle is the repo folder. PuzzleProject holders all the Unreal project files.

folderstructure.png

Also the steps I did:

 

  1. File -> New Repo
  2. Click create
  3. Select Puzzle as destination path
  4. Name was Puzzle
  5. Click create.

 

Tried this several times and no success at seeing any changes in any files or subfolders.

Mike Corsaro Atlassian Team May 23, 2019

Sorry about that! Could you verify the current file filter is set to the correct value?

Try changing it to "All" and then change it back to "Pending":

Capture.PNG

 

If files still do not show up, do the following:

  • Click the "Terminal" button in the repo
  • Run 'git status'
  • Reply back with the result of the command. If there's a ton of files listed don't worry about listing them

Aha! It was set to modified. Setting it back to Pending fixed it so I could make an initial commit. Thank you for your assistance.

Like Mike Corsaro likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events