Latest Sourcetree update is terrible

Not only design changes are really strange - application now looks so crappy but also functionality is not working correctly. Eg. diff functionality after clicking to file is not event showing file, or showing not most recent saved version – it worked well before.

Real step back sad

78 answers

Completely agree;  first, the registration pop which loads the authentication web page never loaded;  After re-launching it, it loaded but was too narrow to see anything;  Finally got past that and now, every time I merge from another branch into my current branch,  the entire UI becomes blocked by what appears to be a hidden/invisible popup.  I can no longer click on the anything and the "quit" option on the file menu is blocked!!  Not to mention the UI looks awful.

the same here, now after merge I have to kill -9 SourceTree process sad

The invisible pop-up issue happens to me as well, need to force-quit all the time

Same problem I'm facing as well.  Merges cause the UI to hang.

I had to try three times before I could re-register the product I paid for and have been using for years. Huh?

Source Tree freezes every time there is a conflict. maybe it's too terrified to make a marge?

Same here, UI freezes all the time...

the freeze on merge is really problematic...   

please, please, please work this weekend to provide a patch, or suggest a  workaround...

Same here as well. I rolled back to the previous version and I will skip 2.2. Hopefully the next update will address this...

I am having the same issue, skipping this update!

 

yep, all problem above and my bookmarks just unrecognized. damn, my works.

same. What a shame from a product that I used to recommend to many professionals.

Have Atlassian outsourced the development of Sourcetree?

Completely agree, it's a shocker.. looking for alternatives, just can't work with it.

New layout is just plain terrible. Why so ugly? Where did the colors go? Reconsider please.

Yeah what was wrong with the previous icons?  Now I have to take screenshots of these new icons for my user guide.  Terrible decision on that one.

I'm okay with the font changes, removing redundant buttons, and decreasing white-space.  Free-ing up screen realstate is a good thing.

But why so monochromatic.  Hurts my eyes.

I have to agree. I stupidly clicked upgrade and now I'm dead in the water with SSH failures. If I do manage to get by I can't fetch, branch or commit anything. It just hangs. Is there a way to back off to 1.7?

I went back to 1.7.  This was a terrible update

Screen Shot 2016-02-22 at 22.35.30.png

Easy login right...

Thx for the links, downgrading.

I will downgrade thanks smile

Looks like last version in 1.7 branch was 1.7.0.36739:

2016-02-27 19-37-42 Found Updates for SourceTree.png

... but it is removed from the Atlassian servers:

2016-02-27 19-39-06 Installing Updates for SourceTree.png

How absolutely staggering.

Color of icons has to be chosen for real users to distinguish items easily and quickly. Your art director may think the new design is cool because of consistent color usage. But .please think again about how real users take advantage of distinctive colors.

 

A design that does not take into consideration user usage and intuition, is definitely not a good design. I have seen better projects made in first year courses of bachelor in design. This looks like "omg look at me so cool" amateur hour design work.

This is a productivity tool, it's not an app that just sits there and looks nice.

People who are using this app are constantly clicking and using it the whole time it's active. A media player for example someone clicks play and then does nothing for an hour while watching.

 

The media player is a candidate for a no-colour interface as the click rate might be 1-10 clicks per hour. This tool people click 100s to 1000s of times per hour which is why colour to find what you need to click is paramount.

Visual Studio made the same mistake a couple of years ago. They went with a monochrome redesign early in the beta process... there was such an outcry that they reconsidered and went back to multicolored icons. 

v 2.2 for OS X El Capitan: application freezes after branch merge.

same here, also the BeyondCompare integration is completely broken sad

Yup. Same here. Git merges have some missing dialog or other UI element that never appears. After a merge completes, you can't do anything. Have to force-quit the app and restart to get back to a usable state.

Indeed - I can't merge - force quit is the only solution. And then I drop to the command line to get work done.

Not only an issue on OS X.  Windows crash after merge / fix.  Every. Single. Time.  Seems Atlassian is looking to send their customers to various competitors.

No need to merge branches to freeze it up. It freezes up without doing anything. sad

Echoing what so many others have said - this latest update is crap. The things that are bugging me the most:

  • Changed icons in the file lists - ok, not huge, but the old + - ... ? made good sense to me, whereas "m" (I assume it's for "modified" - english specific? come on...) doesn't
  • No multiple stage - used to be able to select several files and hit the spacebar to stage them all. Can't find a way to do this now. Very painful, even when it's only 10-15 files to update. Glad I don't have any 100+ file updates coming up.
  • No diff preview when a file is selected in "pending" - the diff stays on the last selected staged file.

Really hoping I can figure out how to downgrade... this is ridiculous.

I used to use the spacebar all the time to stage multiple files. Please bring this back!

(And don't highlight the pipe between the active tab and the non-active tab)

It'd be a real service to your customers to shut off updating till this is fixed .. it's now over 12 hours since reports of a broken update appeared here.

Well, I guess I have myself to blame. It is a FREE license so I guess I cannot expect too much. Learned the lesson, take extreme care when upgrading!!! "Log in to existing account" just show a blank display with a cancel button as only option. DON'T ATLASSIAN TEST? Luckily I have another Mac with the old, working, 2.1, so I could revert on all my Macs. Hope they fix it soon or should I look for another program?

 

Had the same problem, now it appears to work.

I'm still struggling with this one.  I neglected to keep a copy of the older version.

I'd be willing to pay for source tree if they'd just test their product before release. I hate wasting time at work uninstalling source tree so I can reinstall an older version whenever I forget to not update.

I agree with you Benjamin. I will added willing to pay if that means a better support and development for source tree.
Tree view on windows, after 2 long years of asking to have it, is gone again, deprecated because considered slow... so every other software out there must be done with some sort of magic coding... 

Invalid CSRF token found in form body

Atlassian, please test your software rigorously before pushing to the master branch.
I had to reinstall the old version immediately because I was locked out.
Make sure to use the default browser for the login window, not internet exploder.

Sincerely,

Me 

giphy.gif

Oh yes that one... it uses explorer... gosh.

Can't use latest update.  Like others, I can't sign in "Use an existing account" - blank modal shows up - blank.

I liked very much sourcetree... but the new version is unusable and doesn't work. I also prefer the old GUI design with the git-flow button included.

I will try to retorn to an older version...

Totally agree with you.

I miss the git-flow button, please include in next version!!!!!!!!!!!!!! 

It is back (I update to 1.8.2.2 version and it is ok)

That's a shame!

This UI suck so much! is those people do test their app before releasing it ???

It's no more usable at all.

I'm used to select a commit and Press Cmd+R to reload content, it was keeping the selected commit after update done.

Now it always goes to the local latest commit.

Worse, adding a file to the index (staging) also reproduce the problem, making code review a nightmare...

Also, trimming the sidebar text to a hardcoded length makes it totally unusable. No mouseover or click would show me the full name of my branches or stashes, leaving the end-user totally blind:
Screenshot 2016-02-22 11.25.24.png

And this doesn't respond to resize or anything, so there's really no easy way to figure the list items out.

When I made the sidebar smaller than that size it started working correctly.

You're right, if you resize down to make it trim it will actually work. So this is definitely a bug.

Haha, yes! It works, pull it to narrow and then back out again. Nice bug workaround! 

Quite interesting that everybody seems to have a completely different MAJOR issue.

I can't believe such basic features as 'staging' are borked by this release.

It's like Atlassian stopped using their own ecosystem to manage a release. HTF did this pass QA?

 

Ditto. I upgraded this morning. First problem: no bookmarks. Next problem: UI didn't refresh after moving a file from Unstaged to Staged. Next problem: UI froze when switching from File Status tab to Log/History tab.

All this in the first 3-4 minutes! I'm running v1.8.1.0 on Windows 7 x64.

This is pretty shocking.

it gets worse...

 

it just inserted the diff file into my source file

I care less about the aesthetic changes. It was only a matter of time before SourceTree jumped on the flat UI bandwagon. My issue is staging is largely broken if you're trying to stage hunks and lines, which is really what I use SourceTree for. It used to excel at that.

  1. Can't shift click and select lines. Only dragging with the mouse seems to work. Completely backwards from 1.7.
  2. Can't hold shift or ctrl to modify a selection. Have to start over and try again.
  3. Better hope you don't stray out of the box when dragging a longish selection. Kills the drag event and then see #2
  4. If you click on a file in the staged area (to verify/double check what you have staged) good like getting unstaged files to display again. Most of the time they won't. Sometimes if I click around long enough I can get it working again.
  5. Long lines of code (such as SVG) push the stage hunk/lines buttons off the screen so you're constantly scrolling back and forth.

This is on a Windows 7 Enterprise laptop I use at work. Haven't tried it at home on my Windows 10 box and frankly, not even going to bother. I'll be using the link above to rollback to 1.7.

Yep, This is a complete fail update.

Can't stage deleted files. Merge conflicts don't show. UI is terrible.

Going back to 1.7.

Very good update!

First - I can't install it for first time. It's simple don't want loading web page.
Second - even if you login & install app, you can't use app. Then you launch app - it ask your login & pass. And if you give it (or even cancel) - main form still untouchable.

Amazing update. Sometimes I remember 90's with it's CDs. In 90s, if company launch similar update, she is simple going to bankruptcy and don't waste time of anyone.

I can't even delete files the same way I did before! I would previously delete the file in my file system, then simply "check" the unstaged removed file to stage that delete. Now when I do this, I get:

git -c diff.mnemonicprefix=false -c core.quotepath=false rm -q -f -- filter-helper.js
fatal: pathspec 'filter-helper.js' did not match any files
Completed with errors, see above.

I've found I can now delete file by right clicking the missing file in source tree, then deleting from that menu (or pressing ctrl + delete).

Why would you guys change this behavior?

I used to be able to select a changed file in commit view, and press space to select it (which would move it to staged). This doesn't work now.

Was a nice little feature which is horrible now it's gone...

Multiple crashes, incorrect rebase, not good...

I don't care so much for the stetic changes... but mine just keep crashing after a few seconds. I can't do even the simplest tasks.

I'm using Windows 10 on a Dell Laptop 16 Gb RAM

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

647 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you