Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

How do I fix 'http.postbuffer': out of range issue for SourceTree 3.4.2 on Windows?


I tried to fetch from my repo and I got this error. 

    $ git fetch
    fatal: bad numeric config value '9999999999' for 'http.postbuffer': out of range

I tried using this command to set postbuffer to something reasonable.

    $ git config --global http.postBuffer 1048576000

I did this to see if it worked.

    $ git config --get http.postBuffer

I also checked the global setting and saw this.

    $ git config --global --get http.postBuffer

I even looked at my c:\users\[account name]\.gitconfig file to check the value and saw this.

    postBuffer = 1048576000

Then I tried fetching again and saw this.

    $ git fetch
    fatal: bad numeric config value '9999999999' for 'http.postbuffer': out of range

I also tried removing the http.postbuffer setting from c:\users\[account name]\.gitconfig. Then, I queried the value from the command line again. The value was still 1048576000. Then, I tried doing a fetch again. I got the same error and it reported that the value was still 9999999999. So, the .gitconfig file says the value is 0, the command line says that it is  1048576000 and the error message says that it is 9999999999!

Can someone tell me how to figure out where Git/SourceTree is looking for this setting and how I can fix this? 

0 answers

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events