Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How do I enable Sourcetree notification of new pull's are available?

Hello Atlassianites!

After I have committed and pushed to a branch on one computer, opening up SourceTree on another computer (having checkout the same repository with valid SSH keys), SourceTree does not indicate that there are new Pulls to be made (should be indicated by the little red integer above the pull-arrow icon). Pull still works, but there is no notification in the UI that a pull can be made, or that I am one or more commits behind. How do I enable this indication in the UI?

11 answers

1 accepted

1 vote
Answer accepted

Hey there,

Sorry about that, I was reading too hastily. There are a couple of settings that could change this. The first one is in Tools > Options under the General tab "Check default remotes for updates every X minutes". If this is turned off, or you have a large value in there, you may not see changes get fetched.

The second option is in the repository settings on the advanced tab there's a setting at the bottom "Refresh remote status in the background".

If you could check both of these making sure they're set then we can go from there. Also, make sure the branch with changes to be pulled is checked out, then wait a while whilst it does a background fetch to make sure. It syncs up with your tracking branch so doing that will do a background fetch and show the pull count for that branch.

Cheers

This solved it for me by setting the refresh rate to 1 min. Thankyou Kieran.

Is it possible to decouple refreshing from notifying? I would like to have up-to-date views of my repos, but I don't want to be spammed by notifications about it.

Like Laura Pearlman likes this

Hey Fredrik,

Desktop notifications are Mac-only at the moment in case you're using Windows. The setting is in the 'General' tab of your SourceTree preferences. The setting says "Disable desktop notifications" which, if you want notifications to be shown, should be disabled.

Hope that helps

No I do NOT mean desktop notifications, I mean the little red counter next to the pull button in the Sourcetree client top toolbar, see the image below (I know the image is from the Mac client but the UI is the same in Windows).

Here's the thing, at work I have the Windows client, and I can see there are (for example) 2 available pulls. At home I also have the Windows client, but I'm unable to see these notifications. At work, there's a standard server, and at home, I'm using a GIT repository hosted by BitBucket. In both cases, I use SSH and have specifed my private key in Sourcetree.

To clarify, pulling works fine at home, but I dont see the "available pulls count".

/ Fredrik

I have the exact same problem, both at home and at work. This also happens on two separate GIT's, both of them hosted on Bitbucket.

I have the red notication appear in the past but it just doesn't appear at all now, when there are definitely new pulls present.

Both of these are already checked for me.

Hey Chris,

OK, the best route would be to open a new ticket on jira.atlassian.com(project SRCTREEWIN) so us devs can take a look. Sorry for the extra step, it's just all issues are handled by jira.atlassian.comby the devs rather than here.

Thanks in advance

Hi there,

I'm having the same issue suddenly; this was working but has stopped.

I have checked both settings mentioned above and have lowered the refresh time from 10 to 2 minutes but still no change.

Any advice will be much obliged.

I still don't have a good answer. Sometimes the "pull count" is updated after 5-10 minutes or so (despite refresh time set to less), and sometimes it doesn't. 

Hey Fredrik,

I just noticed this is only happening on one repo for me, so I wonder if there are any other settings that could affect it ?

Hi Richard. 

Interesting, thanks for the update!

Same issue here. I got 8 repos on my mac and they all get those little icons to show the available pulls besides one repo. Same settings as far as I can tell for all of them.

The same issue is in the repo browser… Pretty frustrating, and weird.

OK, I'm dumb… I had not enabled track remote on that branch.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,291 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you