Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

HELP !the aucentication is sufccessfull ,but it can not skip the registration step!

E75459A1-08D3-4782-81EA-BBED0EED6909.png7255DB36-ADEC-4ad6-ADBB-66D83D4238C6.png

3 answers

I have tried lots of times.  the problem can not be solved still.Someone give me a tip ? my grat!

0 votes

Clear your browser cache and try again or try using a different browser and check if that works.

I got the same problem trying to install version 3.3.6.

When prompted to I logged into my account but the installer just sits there "Waiting for login to finish" forever.

When I exited the installer and tried again I get the same Authentication Successful page and the installer stuck.

I've cleared the browser cache and now I'm back to the Waiting for login again.

Any ideas?

Many thanks in advance

I got  a way to solve it.

1 step : unstall and clear all the info including the associated of souretree.

2 step: copy the folder of souretree which has been installed and running successfully  to your current computer where you want to use sourcetree  at ;

3) click the souretree.exe which locate in the folder.

4) now ,you will see the resgister pomt.do not close it. and go to "%LocalAppData%\Atlassian\sourcetree". create a "accounts.json" file, then  copy the content below into it and save it   :

[
  {
    "$id": "1",
    "$type": "SourceTree.Api.Host.Identity.Model.IdentityAccount, SourceTree.Api.Host.Identity",
    "IsDefault": false,
    "Authenticate": true,
    "HostInstance": {
      "$id": "2",
      "$type": "SourceTree.Host.Atlassianaccount.AtlassianAccountInstance, SourceTree.Host.AtlassianAccount",
      "Host": {
        "$id": "3",
        "$type": "SourceTree.Host.Atlassianaccount.AtlassianAccountHost, SourceTree.Host.AtlassianAccount",
        "Id": "atlassian account"
      },
      "BaseUrl": "https://id.atlassian.com/"
    },
    "Credentials": {
      "$id": "4",
      "$type": "SourceTree.Api.Account.Basic.BasicAuthCredentials, SourceTree.Api.Account.Basic",
      "Username": "",
      "Email": null,
      "AvatarURL": null,
      "AuthenticationScheme": {
        "$type": "SourceTree.Api.Account.Basic.BasicAuthAuthenticationScheme, SourceTree.Api.Account.Basic",
        "Value": "用户名/密码",
        "Name": "Basic",
        "Description": "密码",
        "HeaderValuePrefix": "Basic",
        "UsernameIsRequired": true
      },
      "Id": "",
      "EmailHash": null,
      "DisplayName": null
    }
  },
  {
    "$ref": "1"
  }
]

4) re-open the sourcetree.exe. you can find the register promt has dispeared. and now you can go on next step.

"

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,251 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you