Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,462,867
Community Members
 
Community Events
176
Community Groups

GitLab EE Account Creation Fails using PAT, with "Authentication failed" Error on SourceTree 3.3.7

I have SourceTree 3.3.7 on Windows.  I tried to add a GitLab EE account after setting up a PAT with api and read_user scopes.  I enter the https URL (with and without trailing '/' as suggested by a user).  I click "Refresh Personal Access Token" and enter the username and PAT.  I have also tried entering the PAT name and PAT, as suggested by a user.  I also tried both the embedded git and system git, as suggested by another user. In all of these instances, I get an "Authentication failed" error that will not allow me to proceed.

I am able to access my remote repositories on GitLab EE and push to them using my username and PAT with command line git.

I can also clone a repository and use it through SourceTree without setting up an account, just setting the username and password when prompted as my username and PAT in GitLab. I'm not sure why the account creation doesn't work if I can setup a repository and use it with the same credentials. 

1 answer

Same issue with SourceTree v3.3.8.3848. Tried with username and PAT, token name and PAT, created a token with the same account name, tried with and without trailing '/', tried new fresh installation, new ssh key pair but I always get "Authentication failed"

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events