Download your SourceTree license (broken link)

hello

I register to get a sourceTree licence, but the link to download doesn work.

License Key:
Download your SourceTree license. Within SourceTree select from the menu bar "SourceTree > Registration", click "Import License" to import the downloaded the license file.

Whe I click on "Download your SourceTree license" i got:

No webpage was found for the web address:https://my.atlassian.com/license/file/xxxxx

13 answers

Hey all,

This has been reported to our internal system admins. In the meantime, however, you can still get your license file using SourceTree itself. On Mac go to the SourceTree menu and hit "Registration", from here you can login to your my.atlassian.comaccount and it'll automatically download your license file. The same applies to Windows, except the option is in File > Registration.

Cheers

Product improvement suggestion:

Before coming to this thread, I had no idea you could just do this. Would it make more sense to steer the user down this route than suggesting that they download a file from the website?

There is no File > Registration for my sourcetree, it's version is 1.9.6.1. So my issue is that how do I import the downloaded license?

 

Thanks,

Jing

I'm also unable to find "Registration" under the Sourcetree menu in the menu bar. Please help.

SourceTree for Mac (version 2.3.1)

 

Thanks.

Just to let everyone know that this issue has now been resolved on my.atlassian.com, you should all be able to download your license manually. Just as a sidenote though, it is possible to do all of this within the app itself without having to go directly to my.atlassian.com.

Cheers

Have you looked at the licenses you own on the base https://my.atlassian.com/productlink.

It should show there if you have one.

hi, when use this url https://my.atlassian.com/products

I can see that I have a license:

Licensed To: Me
License Key:

When I click on it directs me to the url referred on the original message:

https://my.atlassian.com/license/file/3540079

getting: No webpage was found for the web address:

This is happening to me as well.

Exact same, have the link and it opens to an error page, generated by browser not site, so looks like server side error: Error code: ERR_FILE_NOT_FOUND

I've just got the same problem

File not found

Can't download Sourcetree license from page https://my.atlassian.com/products/index

I've tested this too with an existing/new license and get exactly the same error with the file not found. Existing license in my list also has a download link that fails.

Same problem. I can report that the in-app registration process worked fine. Thanks Kieran.

Yup same probelm for me, cannot download the license. On chrome -> "This page is not found" and same 404 on Firefox.

Hey Ramitha. My answer above will help you out.

Hi Kieran,
I'm on mac, when I click on Registration under Source Tree all I see is Import License and Register Now - Free! apart from Close, where do I sign in to my.atlassian.comfrom the app??

Thanks

Same problem for me.

Hey Oliver. Take a look above and my answer should help you.

Thanks, all sorted.

My trial period expired so that solution does not work for me I got two options Import or Drag license

My trial period had also expired and it did work for me. Sourcetree asked me for my username and password and automatically installed the license.

To solved I unistall the produc install again at that point I folow Kieran recomendation

What I did to solve it:

- Unistall SourceTree

- Install it again

- Follow Kieran instrunctions

Thanks to all

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

747 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you