It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot get past the Sourcetree Bitbucket registration page Edited

on the registration page, i click bitbucket.  i log in  with my email address j******n@b******.com.  i have an account and it successfully authenticates me.  the page that is titled Confirm access to your account and lists the requested access items.

I push the button "Grant access" and nothing happens. the sourcetree returns to the registration page.  

I am unable to get past this.

2 answers

0 votes

Hi James, welcome to the Community :)

We'll need more info to help you troubleshoot this issue:

  1. Are you using Bitbucket Cloud or Server?
  2. Are you using Sourcetree for Windows or for Mac?
  3. If you're on Windows, is Internet Explorer updated to the latest version?
  4. Can you login to id.atlassian.com using the same credentials?
  5. If you're still unable to proceed, can you send us a screenshot?

Let us know!

Ana

 

PS: I've edited your message to remove your email address for security purposes.

Thank you.

1. Bitbucket cloud

2. Windows 7 (this is a shared VM)

3. yes, everything is upgraded. coworker, with copy of the same VM doesn't have a problem.

4. yes, i'm able to authenticate fine. web page says Authentication Successful, close this page. When i go back to the Sourcetree app, it's on the Registration page again.

2018-11-14_16h08_45.png

I encounter the same situation. I am using Bitbucket cloud under Windows 10 with IE11. Login to id.atlassian.com is fine. After entering credential and granting access, it shows "Authentication Successful S". Then the installer changes from "Waiting for login to finish..." to "Registration" page but the "Next" button is still disabled (Refer to James's screenshot). 

 

I have tried many methods found on the web, for example, adding the domain to the trust site, allowing META-REFRESH and Active Scripting, disabling the compatibility view, uninstall the app and restart PC then retry, don't use google account, clear the IE cache,etc...

 

It is still not working. Please help.  SourceTreeAuthenticalSuccessful.PNG

Any solution to this issue, because I'm also encountering this problem.

Like # people like this

Any solution yet? I'm encountering this problem now.

Like Wayne Hughes likes this

Is there a solution yet? I can get this to work on my desktop but not the laptop.

Thanks.

Seems fruitless to keep asking for a solution, but I have also experienced the same thing on Windows 7. Successful authentication, SourceTree seems to be aware of the successful authentication, but grayed out 'Next' button.

Like kjjeon likes this

Same issue here, Windows 10, granting access with mozilla...

I am experiencing the same problem, I cannot get past the Registration page.

It was working earlier today, but I saw an update available, and I clicked update. After updating, it hasn't worked since.

I hadn't used Sourcetree on this machine since Nov 2019, so I was using an old version of sourcetree this morning, and the old version worked fine.

I will try to re-install old version.

I went to /%UserProfile%/AppData/Local/SourceTree/ and two of the folders are:

  • app-3.2.6
  • app-3.3.8

version 3.3.8 doesn't work (can't get past registration), so I went to version 3.2.6 which works fine.

Full path: %UserProfile%/AppData/Local/SourceTree/app-3.2.6/SourceTree.exe

I will pin that to my taskbar, and unpin v3.3.8

Like # people like this

thanks Peter

I am also having this problem on Win 7. Exactly the same behavior. I  only have the 3.3.8 version of SourceTree. I signed up for Bitbucket Cloud. Why can't they fix this??

Probably because issues specific to Windows7 are ignored at this point. I think we need to accept that support for that OS is over.

It happened for me on Windows 10.

Ah. Then I will revert to my previous statement of "issues pertaining to Atlassian products are ignored by Atlassian at this point".

I installed a 3.2.6 which worked fine. Then after connecting I upgraded to the most recent version from within Atlassian.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,970 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you