Can't delete missing files error : fatal: pathspec ''file did not match any files.

I Have missing files in my project but I can't delete this ghost files.

I tried to removed them with SourceTree I also tried to ignore the folder and stop tracking files.

When the file is restored I see the same file twice.

Please help :(

Here the error

3 answers

1 accepted

1 vote
Accepted answer

Finally I deleted the folder on Windows wihtout any problem.

Conclusion : Never use special chars on file names :(

I'm guessing the special characters in the folder name are causing problems. Especially the apostraphe in j'ecris.

Pearhaps.

Actually I renamed the folder without spaces and special chars.

But how manually remove index files in git ?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

832 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you