Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,632
Community Members
 
Community Events
176
Community Groups

Bitbucket will not connect with Sourcetree

I am trying to connect up Sourcetree to my bitbucket however,after attempting both HTTPS & SSH none of the options work. The issues with both HTTPS & SSH are different and I have attached screenshots of both issues I am encountering.

HTTPS: authentication completes and I can access the repository however, when attempting to clone I receive: "This is not a valid source path / URL" when looking at the details it references an invalid username and password however after checking these I can confirm they are correct and there are no cached passwords

SSH: Authentication once again completes and the repository type is detected however when trying to clone the repository I receive: "FATAL ERROR: server unexpectedly closed network connection".

I have also tested older versions of source tree as well as re-adding my account and refreshing the auth tokens however nothing has worked so far please advise.

1 answer

Screenshots of the issue are below

Hi, 

I had a similar thing happen. I reset the password and even re-installed the software. 

I had no put a credentials manager at start up so I had to do a bit of powershell to get around this: (open as admin)

"cd $env:LOCALAPPDATA\Atlassian\SourceTree\git_local\mingw32\bin\" (without quotes)

then:

"./git.exe config --edit --system" (without quotes)

Inside this file i had to add the word "manager" (without quotes) at the end of the file at the line  "helper ="

manager.PNG

Then just quit out like VIM ( press ESC until you are out of insert mode and then":wq" without quotes)

Hi John, 

 

That's worked for me thanks for your help!

Like John Hardiman likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events