Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

After upgrading to Sourcetree 3.2.6 getting error as GIT not found

Hello Team,

 

I just have updated SourceTree (3.2.6)and installed updated version of GIT 2.24.0.2 .  Post this update I am unable to open specified repository which are checkedout previously .

I am getting error GIT not Found.Even when tried with the option of Browsing the location on local machine it is not proceeding further . I have tried uninstalling and installation couple of times but still no luck.

Can anyone help me over here.

I am using the laptop (running Windows 10 x64). 

1 answer

1 accepted

0 votes
Answer accepted
Ana Retamal Atlassian Team Nov 13, 2019

Hi Paresh, welcome to the Community!

I see your install of Sourcetree is having trouble to find Git. Can you switch from system git to embedded git and see what happens?

Sourcetree will try to find and use an existing Git installation rather than download and install its own local copy.

It does this by checking the PATH, looking in some standard locations, e.g. c:\program files (x86)\Git or asking the OS to find it.

If it finds a git.exe through any of those methods it tries to run

>git version 

and parsing the output, if it matches a supported version it will configure itself to use that Git installation.

If it can't find a git.exe it will prompt you to try and look for it.

Where is your Git installed?

It sounds like Sourcetree might be finding the installation bur for some reason the git version call is failing.

Is there anything in the %localappdata%/Atlassian/Sourcetree/sourcetree.log showing errors when trying to run git version ?

Let us know!
Ana

Hello Ana,

 

When tried with embedded version initially it failed but after restart of SourceTree it worked all fine.

 

Thanks for the help :)

Ana Retamal Atlassian Team Nov 15, 2019

So glad to hear that, @Paresh Shidruk !

Have a good day,

Ana

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,261 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you