how to share clover artifacts from bamboo windows agent to bamboo on linux server

i having a bamboo server setup on linux. i have a build setup on a windows agent followed by unit tests and clover code coverage. the clover report is generated, but it's not copying the artifact.

there are some other builds which have agents on linux. in those cases it copies the artifacts and i am able to view the reports from bamboo.

If you have come across this issue, please help.

8 answers

bamboo version is 3.3.4

0 vote

Can you confirm that by "copying the artifact" you mean the artifact sharing feature?

Or ... maybe a fact that an HTML report generated by Clover is being found by Bamboo as per artifact definition?

Do you use manual or automatic Clover integration?

Do you use Ant or Maven for build?

Do you see any error messages in a build log?

Thanks for your response.

I want the clover reports to be integrated to bamboo. There is a clover tab which shows a link "View latest Clover information". when i click this link i want to see the clover reports.

For this to show up, i thought that we need to use the artifact sharing feature. in the build >> configuration >> produced artifacts section there is a link for "Clover Report (System)". i am trying to share the artifacts here. it is not uploaded to this link.

initially i thought there's an issue with the patterns, i tried different patterns

Finished publishing of artifact Job artifact: [Clover Report (System)], pattern: [**/*.*] anchored at[latest/Engineering/junitreports/clover/html] in 0s

the same response is for

[**/*] anchored at latest/Engineering/junitreports/clover/html,

[**] anchored at[latest/Engineering/junitreports/clover/html]

[**] anchored at[latest/Engineering/junitreports/clover/html]

[**/*] anchored at[latest/Engineering/junitreports/clover/html]

[**] anchored at[Engineering/junitreports/clover/html]

------------------

then i found that none of the artifacts are being shared from windows to linux including the default artifact Build Directory.

it's an ant build, manual clover integration.

I see this error in the build log:

Running post build plugin 'Clover Results Collector'
13-May-2014 11:49:38 Failed to execute plugin 'Clover Results Collector' with error: No file matches the specified pattern:latest/Engineering/junitreports/clover/clover.xml

Thanks for your response.

I want the clover reports to be integrated to bamboo. There is a clover tab which shows a link "View latest Clover information". when i click this link i want to see the clover reports.

For this to show up, i thought that we need to use the artifact sharing feature. in the build >> configuration >> produced artifacts section there is a link for "Clover Report (System)". i am trying to share the artifacts here. it is not uploaded to this link.

initially i thought there's an issue with the patterns, i tried different patterns

Finished publishing of artifact Job artifact: [Clover Report (System)], pattern: [**/*.*] anchored at[latest/Engineering/junitreports/clover/html] in 0s

the same response is for

[**/*] anchored at latest/Engineering/junitreports/clover/html,

[**] anchored at[latest/Engineering/junitreports/clover/html]

[**] anchored at[latest/Engineering/junitreports/clover/html]

[**/*] anchored at[latest/Engineering/junitreports/clover/html]

[**] anchored at[Engineering/junitreports/clover/html]

------------------

then i found that none of the artifacts are being shared from windows to linux including the default artifact Build Directory.

it's an ant build, manual clover integration.

I see this error in the build log:

Running post build plugin 'Clover Results Collector'
13-May-2014 11:49:38 Failed to execute plugin 'Clover Results Collector' with error: No file matches the specified pattern:latest/Engineering/junitreports/clover/clover.xml
0 vote

Thanks Vinay for providing more details. There are several topics touched here.

1) Artifact definition

In order to see a 'Clover' tab with an embedded HTML report, a Job must have at least one artifact defined, which will contain the HTML report produced by Clover. By default it's named "Clover Report (System)", however it's also possible to use a different name. There is no difference whether such artifact is shared or not. It just have to be present and filled with files.

According to what you wrote, the artifact definition with a path "latest/Engineering/junitreports/clover/html" and a copy pattern "**/*" should be fine.

2) HTML and XML reports

In order to fully utilize Bamboo Clover Plugin, a Clover configured in the build (in your case - an Ant-based build) must produce reports in two formats:

  • HTML format - it will be packed into the "Clover Report (System)" artifact and displayed on a 'Clover' tab
  • XML format - it will be parsed by Bamboo Clover Plugin in order to gather some statistics - you can find them on the 'Metadata' tab for a build; they're also used to draw a coverage bar on a plan summary

I suspect that you're generating an HTML report only in your Ant build - am I correct?

3) Providing correct location for XML file

As you wrote, you have an error related with Clover Results Collector:

Failed to execute plugin 'Clover Results Collector' with error: No file matches the specified pattern:latest/Engineering/junitreports/clover/clover.xml

When you're using manual Clover integration in Bamboo, then on the Build configuration page, on the Miscellaneous tab there is a field named "Clover XML Location". You must put a correct path to the XML report produced by Clover.

Cheers
Marek

i'm generating both html and xml results. and am giving the clover xml location as "latest/Engineering/junitreports/clover/clover.xml". the build directory is e:/i/ut/mdx/0050_ind/Engineering/junitreports/clover. i tried giving the below paths but it fails.

[**/*.*] anchored at[latest/Engineering/junitreports/clover/html]
[**/*] anchored at latest/Engineering/junitreports/clover/html,

[**] anchored at[latest/Engineering/junitreports/clover/html]

[**] anchored at[latest/Engineering/junitreports/clover/html]

[**/*] anchored at[latest/Engineering/junitreports/clover/html]

[**] anchored at[Engineering/junitreports/clover/html]

latest is a symlink i created in windows and points to Engineering/... i did this to make it similar to the linux builds.

Another observation i made is if i scp the content to /app/bamboo-home/artifacts/UTCLOVER/BUILD/build-00045/Clover-Report-(System), it is integrated from bamboo. i can view all the contents from clover.

i am not able to figure out the path where it is looking from. is there any way to find out the path from where it is looking for the /latest/Engineering/...



0 vote

latest is a symlink i created in windows and points to Engineering/... i did this to make it similar to the linux builds.

How did you create the 'latest' symlink on windows?

i used a utility called "junction"

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published yesterday in Off-topic

Get to know our Atlassian User Group Leaders from Bengaluru, India

Meet @Dinesh Dhinakaran, @Vishnu Vasudeva, @Rajeev Verma, and Jamshid Nalakath: Our extraordinary AUG leaders from Bengaluru, India. These four work together to strengthen the bonds of their local co...

146 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you