When creating new Gliffy diagram return to confluence button does not work resulting in partially edited page

When creating new Gliffy diagram return to confluence button does not work resulting in partially edited page.

1. In confluence space, click on page, then from drop down select add gliffy diagram

2. Confluence goes into edit mode and asks you to select choice of Gliffy diagram style

3. Select gliffy diagram style and create diagram in Gliffy.

4. Click Save in Gliffy

6. Click Return to Confluence, button changes color then nothing happens

7. Observe as nothing happens and screen is non-responsive to gliffy edits. Clicking Return to confluence again does nothing. Clicking on File button sometimes goes back to confluence dashboard not to page where you were editing. Other times it does nothing. Pressing back button returns to confluence dashboard.

8. Once at confluence dashboard clicking on page you were editing before shows old page without any chages or gliffy diagram.

9. Clicking on edit page again many times brings up a warning message that edits are in progress, do you want to view, continute editing or abandon.

10. Click on continue editing and then the page opens up with the Gliffy png of the diagram you were editing and the Gliffy macro correctly in place

11. Click on save page and then finally the page is correctly saved as originally intended.

12. Warning message does not always show up allowing you to continue editing and in that case there is no gliffy diagram on page. Looking at the attachments for the page, the gliffy png and gliffy diagram are shown on the attachements list, but the gliffy macro is not on the page and there is no way to access the gliffy diagram from the page.

In either case this is bordering on unusable to create new Gliffy diagrams.

2 answers

0 vote

Hi,

I've tried to replicate this error on your instance, but I'm not able to. So this may be a browser compatibility or a problem with your local cookies and cache. Could you try a different browser for me, and let me know which browser you're using, which one you've used and the version of flash you're on.

Cheers,

Matt

I am using Chrome Version 23.0.1271.97 m which it tells me is up to date. I have Flash version 11,5,31,5 installed which is the latest. Problem shows up here.

I had not used Gliffy on Firefox because I had issues with the flash before, but I just downloaded the latest flash player for firefox 17.0.1 (11.5.502.135) and it works ok. So the problem seems to be with Chrome. Can you reproduce it with the Chrome version above?

Sorry for my delayed response, using Chrome 23.0.1271.97 I'm not able to replicate the error. Perhaps clearing your cookies and cache in chrome will help. Otherwise it may be worth getting in contact with Gliffy directly as they may be aware of a problem in their product.

I have tried resetting the browser cache/cookies but it still happens on my Chrome. For now I am working around it by using Firefox for any Gliffy work. Got an email from Gliffy that they will be rolling out HTML5 version soon, so I will wait to see if that fixes it since the current one will be replaced.

I'm having the same problem, just started today. We are an On-Demand client. Chrome Version 24.0.1312.57

I use Gliffy all the time and this is the first time I have had this problem.

Updating my JAVA and relaunching Chrome seems to have resolved the issue for me.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published yesterday in Hipchat

Moving from Hipchat to Stride? Here’s what you’ll love

Heya, Hipchat friends! We’re so happy you’re checking out   Stride. Whether you know it or not, you have been instrumental in making Stride come to life. Every feature, design, and functionality...

59 views 2 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you