Hi all, we have small plugin in our company for reports generation in needed format. We use tempo API to get worklogs but we have 3-4 JIRA.
When I build request to Tempo API:
with cred: 

beforeSend(xhr) {
xhr.setRequestHeader("Authorization", "Basic " + btoa(config.credentials.email + ":" + config.credentials.password));
jirahostUrl1 + '/rest/tempo-timesheets/3/worklogs?datafrom=someDate&dateTo=someDate'

First JIRA sent worklog response  for logged in user (credentials in request header), but second sent worklog response for ALL users.

If I make request like this:

jirahostUrl1 + '/rest/tempo-timesheets/3/worklogs?datafrom=someDate&dateTo=someDate&username=someUserName''

Second JIRA sent  worklog response for logged in user, but another JIRA sent response an empty array. 

What I do wrong here? Maybe we need change some JIRA settings/premissions? 


1 answer

I have the same problem.... 

Suggest an answer

Log in or Join to answer
Community showcase
Jason Wong
Published Tuesday in Agility Beta

Welcome to agility

Every team in the world is unique, and so   Atlassian believes   that each and every team's best way of working  needs to  be molded to their unique circumstances  – ...

454 views 7 16
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot