Confluence REST API: Search returning 404 for all CQL queries

I am trying to use Confluence REST API and cannot get the "search" resource to return results.

I have tried many variations in the cql parameter but cannot get anything but a 404.  I have been referring to https://docs.atlassian.com/atlassian-confluence/REST/latest-server/ for sample queries, so one example of a URL I tried is http://confluence/rest/api/search?cql=siteSearch~'example'.

The response is always along the lines of:

<status><status-code>404</status-code><message>null for uri: http://confluence/rest/api/search?cql=siteSearch~%27example%27</message></status>

I am able to get results from the content resource on the same server, eg, http://confluence/rest/api/content?type=page.

What am I doing wrong?

1 answer

0 votes
Gonchik Tsymzhitov Community Champion Oct 11, 2018

Hi!

 

Have you fixed it? 

I have met this error, error was related incorrect json header. 

request.addHeader("Content-Type", "application/json")

Cheers,

Gonchik Tsymzitov

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Canada

Happy New Year - First AUG of the year - great success

Hi Everyone, Hope everyone had a great holiday season and is ready for an exciting 2019.  We had our first AUG last night featuring Tempo Timesheets.  A great presentation and lots of int...

17 views 0 1
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you