Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,022
Community Members
 
Community Events
176
Community Groups

API integration problem

Hi all, I am trying to create an alert via the API. But I run into some problem using the POST. Before this, using GET with list alerts is working fine. 

As you can see in the screenshot I am using:

Content-Type: application/json

Response: Content type 'application/octet-stream;charset=UTF-8' not supported

Any idea?

Naamloos.png

 

 

1 answer

1 accepted

0 votes
Answer accepted
Nick H Atlassian Team May 09, 2022

Hi @Bart Scheltinga ,

It could be the API key being used in your request. The Create Alert API needs to use an API key from an API integration.

If you are using an API key from the API key management tab, POST / creating alerts through one of these is not supported.

Hi Nick! Thanks for the fast response! 

I used the same with GET method and it worked there. Don't think the key is the problem. I used API Integration within team.

Bart

Nick H Atlassian Team May 09, 2022

Ok, thanks for checking. That error is pretty specific, and mentioning the wrong Content Type might be being used (which I understand contradicts your screenshot):

ct1.jpg

ct2.jpg

yeah strange, right? Maybe I should use postman for testing instead, just to rule that out.

I installed Postman (just like you). Now the request works so the problem seems to be on my side!

Thanks Nick!

Like Nick H likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events