It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Trouble Connecting Jira Core 8.1 to MySQL 5.7.26 Edited

Hello,

Spent two days trying to move Jira 8.1 server install to MySQL 5.7.26 but keep getting 'This MySQL instance is not properly configured...' error message.

Followed all the threads I could find online about configuring SSL but the error message persists. Now I want to connect without SSL which I tried several times initially.

When I use the config.sh tool I get the following message:

Wed May 15 15:24:14 BST 2019 WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
Connection successful!

The error message after restarting the server and going through the setup wizard:

This MySQL instance is not properly configured. Please follow the documentation for MySQL 5.7+ setup.

Have been following this document to get the server connected to MySQL 5.7.26 (amongst others describing how to use SSL but not interested in that right now as both DB and server reside in close proximity)

https://confluence.atlassian.com/adminjiraserver/connecting-jira-applications-to-mysql-5-7-966063305.html

The document above asks us to use config tool to configure the dbconfig.xml file then restart the server but when I do that I get sent back to the configuration wizard, basically going around in a loop! When I reach the wizard the My Own Database (recommended for production environments) option is chosen but keep getting the same error message (must have tried more that 30 times)

Here is the JDBC connection string as amended in dbconf.xml

<url>jdbc:mysql://address=(protocol=tcp)(host=mysql-server)(port=3306)/jiradb?useUnicode=true&characterEncoding=UTF8&sessionVariables=storage_engine=InnoDB&useSSL=false&verifyServerCertificate=false</url>

Have inserted the following in mysql.conf.d/mysqld.cnf

# Jira
default-storage-engine=INNODB
character_set_server=utf8mb4
innodb_default_row_format=DYNAMIC
innodb_large_prefix=ON
innodb_file_format=Barracuda
innodb_log_file_size=2G

After Trying SSL connection and getting the exact same error I'm no longer pursuing the SSL route for the reasons mentioned above and the sake of creating a simpler environment.

Edit:

We're using mysql-connector-java-5.1.47

0 comments

Comment

Log in or Sign up to comment
Community showcase
Posted in Atlassian Cloud Migration

NEW: Jira Server to Cloud migration planning guide

Hello Atlassian Community! We're pleased to announce the availability of a new Jira Server to Cloud migration planning guide for customers and partners who are interested in moving to our Jir...

543 views 2 7
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you