No templates shown in Outgoing Email Template Editor for JIRA

After installing this all I see is:

HTML Templates
Text Templates
Subject Templates
With no templates listed. Is there anything else needed to get these to show?

5 answers

1 accepted

Hi Matt,

I try to find something new and there is a bug on Atlassian labs: https://bitbucket.org/atlassianlabs/jira-outgoing-email-editor/issue/1/no-templates-showing-to-edit. This is exactly your case. So we can only hope, that developers solve it soon.

Petr

Lets see what that brings. Thanks

Hi matt,

normally not. Maybe you should try to disable and enable plugin or restart Jira server. In Jira 6.1 is this editor included and is not necessary to install it individually. What version of Jira do you have?

Petr

Hi,

I tried restarting and re-installing it, still no luck.

I'm using v6.1.2

If has "JIRA" group or member rights for read on the server and you don't change it using "chmod" or "chown", there is no reason to not show the templates in web administration. You should raise ticket to attlassian for some help. :-(

Which Jira group are you referring to? We use LDAP user validation for the accounts...

I have now also re-installed Jira v6.1.5 from scratch, with new DB too and the email editior is not showing. Is there anything else that needs to be enabled? Seems there may be a bigger issues with this then?

I assume, that you use a Standalone version. If yes can you cehck if there are the templates located on server in /srv/JIRA install dir/atlassian-jira/WEB-INF/classes/templates/email? You should see HTML and Text directory and there should be ".vm" files. If not, you probably need to reinstall JIRA. I don't know if will be enough to simply copy templates to these directories.

We are using 6.1.2 too and no problem with missing templates.

Yes we are using stand alone - I checked the directories and all of our templates are present in both folders.

I have tried re-installing Jira (to new v6.1.5) and still no luck.

I've just finished installation of jira 6.1.5 standalone from scratch and then installed email editor. The result is, that all of HTML, Text and Subject templates are visible and accessible. Can you find in jira logs some information about email editor error? Or can you check what permissions are set on templates directory /WEB-INF/classes/templates? We are using Owner "jira" and Group name "jira". This owner has permission to read/write, execute/search and we have allowed read by others and execute/search by others. If yours permissions are the same, raise the ticket to atlassian.

One Idea. I tested visibility with IE, Firefox and Chrome - all latest versions. Visibility is OK on all used browsers. But using Chrome and Firefox was not visible Help and Administration Icon, as you described above. But it has no impact on Email Editor functionality. All templates are visible. What browser are you using?

I am using Firefox (latest version) and also tried IE 9, neither work. Guess we are going to have to live without this as this is not supported via Atlassian..

Not sure we want, or should have to change permissions on any of the basic installation folders either.

Thanks for the help in trying to resolve.

OK :-) you can still change email template on server directly. Email Editor only brink this templates to jira webside but if you do some changes in email template, you have to still restart jira server.

:-) Sorry for bad description. I mean account on server created on installation. It could be "jira" and "jira should be owner of Templates directory and subdirectories and must have rights for reading and etc. But if you reninstall whole Jira app, the reinstallation process creates new directory tree and set all rights as new. So this is very interesting issue.

I've also noticed when selecting the 'Email Editor' link, the 2 icons for Help and Administration (top right corner)dissappear.

hi,

im having the same problem, ive tried chrome, IE and firefox, i even gave access to "Everyone" on the email folder but still the same issue, did you find a solution for that?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Bridget Sauer
Published Thursday in Marketplace Apps

Calling all developers––You're invited to Atlas Camp 2018

 Atlas Camp   is our developer event which will take place in Barcelona, Spain  from the 6th -7th of   September . This is a great opportunity to meet other developers and get n...

227 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you