Issue importing test cases using zfj-importer-utility - JIRA (v6.3.10) and Zephyr (v2.5.0)

It says successfully imported and I can also see a success folder created in the same location as of my excel sheet but nothing gets imported to JIRA. When checked the logs clearly on utility it has the below error

Mon Jan 05 16:40:44 IST 2015 file:///C:/APTRA Mobile Banking/Connections/TestsWithStepsInExcel/Test Import.xls normalization success..!
Mon Jan 05 16:40:48 IST 2015 Unable to add testcase ending at rowNumber - 2. Error:Unexpected response code: 400
{"errorMessages":[],"errors":{"customfield_11920":"Operation value must be a number"}}
Mon Jan 05 16:40:49 IST 2015 Unable to add testcase ending at rowNumber - 8. Error:Unexpected response code: 400
{"errorMessages":[],"errors":{"customfield_11920":"Operation value must be a number"}}
Mon Jan 05 16:40:50 IST 2015 Test Import.xls imported successfully..!

image2015-1-5 17:29:59.png

image2015-1-5 17:26:15.png

Not sure which customfield is it refering to? Can anyone help me provide a solution?

5 answers

This widget could not be displayed.

Hello Sunil,

By the log trace it seems the customfield_11920 values submitted are not valid. Please check which field represents  to customfield_11920 by searching on page source. For this navigate to Tests -> Create Test, on the create issue screen right click and select "view page source" which open the page source in other tab/window. Now search for "customfield_11920" which shows the field that corresponds to it.

Please check the mapping of that field in importer and the value that passed are valid.

Kind Regards,

Swapna Kumar Vemula.

This widget could not be displayed.

Hello Sunil

 

I have created a case for you in our system and will be communicating on the same

 

Kind Regards

Pooja

This widget could not be displayed.

Im facing same issue. Is there a resolution on this ?

This widget could not be displayed.

Hi @Sunil Runkana

Our support team had contacted you with respect to this issue by logging a ticket 8584 but we couldn't hear back from you.Can you let us know if the issue mentioned here got resolved?

 

Hi @Kanchan Jawalekar

Would it be possible for you to send us the sample excel file you are trying to import? Additionally please verify if the custom field "Account" is a numeric type ? 

Thanks

Zephyr Support

 

Hi Arun,

 

Apologies but the issue occured on staging version of JIRA. Later when we tried it on production version, the import was successful. That was the reason I didn't get back, apologies for that. 

But now the same issue occurs on Production version as well, used the latest version of utility and also attaching the excel sheet used. But this time the wording of error notification is different but facing issue with the same field ("Account")

No enum constant com.thed.model.FieldTypeMetadata.JiraDataType.account

This widget could not be displayed.

Hi Swapna,

Thanks for your answer and I did that and the issue is with field "Account". But the issue occured on staging environment and worked fine on Production. But the same issue with the same field again has re-occured on Production environment for another project.

 

Thanks

Sunil Runkana

Hi Sunil,

ZFJ Importer Utility has limited support to custom fields that are created by other plugins. As the field "Account" is created by tempo it is throwing error. Please make that field as optional from the custom field configuration with the help of your admin and try to import again. 

By making the field optional will import successfully. Once you import the tests the same can be reverted to mandatory. 

Thanks,

Zephyr Support

We are having the same issue with a Project Select field.  Are there any plans to fix this issue?  Have you tested with the Project Select Field?  In your tests, does this work?

 

We have a Project Select Field

Tue Nov 07 19:50:51 IST 2017 Unable to add testcase ending at rowNumber - 14. Error:Unexpected response code: 400
{"errorMessages":[],"errors":{"customfield_13603":"Could not find valid 'id' or 'value' in the Parent Option object."}}

 

We have a standard Multi Select Field

Tue Nov 07 20:02:48 IST 2017 Unable to add testcase ending at rowNumber - 1. Error:Unexpected response code: 400
{"errorMessages":[],"errors":{"customfield_12900":"Test Type is required."}}

 

Shalom,

Matthew

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 22, 2018 in Marketplace Apps

How a Marketplace app tech team is achieving gender diversity

Hello! My name is Genevieve Blanch, and I'm the Marketing Manager at RefinedWiki, creators of apps to give teams the tools to customize Atlassian platforms. Currently, 44% of the tech team at Re...

513 views 3 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you