Behaviours do not work with Clone plus plugin. Edited

Hi, I am using both behaviours and clone plus plugins. However when I am "cloning" via clone + into another issue type, the behaviours do not apply. The behaviours will only apply if I clone into the same issue type. It is a bummer because our behaviours are mandatory to the issue creation, and the clone + plugin is mandatory for some of our users needs. 

In a word, I would like to clone from issue type X into issue type Y and have the behaviours from issue type Y apply.

 See this issue

Thanks for your help ! 

1 answer

0 votes

Do you have the correct behaviour mapping? You'll need to make sure the behaviour is mapped to both of those issue types (or all issue types). See image below.

Screen Shot 2017-07-19 at 12.09.56 PM.png

It works, but it feels dirty. Most of the time the plugin will try to apply the behaviours to an issue that is not the correct issuetype (unecessary processing). Moreover both my issue types have their own behaviours, meaning that if a field is shared by the two issuetypes, it will be affected by the two behaviours, which can be doing two different things.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in Marketplace Apps

How to set up an incident workflow from the VP of Engineering at Sentry

Hey Atlassian community, I help lead engineering at Sentry, an open-source error-tracking and monitoring tool that integrates with Jira. We started using Jira Software Cloud internally last year, a...

1,686 views 3 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you