Artifactory Generic Deploy: 0 artifacts were found

I'm having troubles defining the right deploy pattern for "Artifactory Generic Deploy".

Pattern:

LIB*.ZIP=>lib/1.0-SNAPSHOT
BUILD*.ZIP=>build/1.0-SNAPSHOT

Results in

For pattern: LIB*.ZIP 0 artifacts were found
For pattern: BUILD*.ZIP 0 artifacts were found

I have tried everything I could think of with exactly the same result - 0 artifacts were found.

Artifacts consist of two zip files in the root of build directory named like LIB-1.0-1231231.ZIP

DIR command with the same pattern list the files.

I've tried changing the file name into simple LIB.ZIP, using lowercase, leading ./, leading .\, leading /**/ etc with same results.

I suspect this deployment task goes into different working dir? How can I check this?

We're running bamboo 5.1.1. Any help or hints very much appretiated!

Update

It looks like file pattern is not the problem. I found out that if I disable all previous tasks, Generic Deploy finds the artifacts.

I incrementaly enabled them one by one and Generic Deploy was working until I enabled the first task - Source Code Checkout.

This task checks out multiple SVN repositories into different Checkout Directories.

I thought it changed the current directory so I added a simple nant target to echo current directory and run the build with disabled and enabled SVN Checkout.

Current directory before Generic Deploy task was the same for enabled and disabled SVN Checkout. So it is not the current directory that gets changed but something else.

Any idea?

4 answers

1 accepted

This widget could not be displayed.

I've found a workaround - I've added ${bamboo.build.working.directory} to Deploy pattern:

${bamboo.build.working.directory}/LIB*.ZIP=>lib/1.0-SNAPSHOT
${bamboo.build.working.directory}/BUILD*.ZIP=>build/1.0-SNAPSHOT

It works even when Source Control Checkout task is enabled.

Bamboo (plugin) bug?

This widget could not be displayed.

Thanks for the workaround! I have been banging my head against the desk all day.

This widget could not be displayed.

Awesome! You saved my day (at least this day) ... spent already nearly a whole day figuring out what is wrong ending up at the same conclusion than you: if you disable the checkout task, the deploy task works fine.

 

The workaround works fine and is still a necessary solution! Maybe somebody from JFrog needs to look into this as well.

This widget could not be displayed.

Can I have this task throw an error if this occurse?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 22, 2018 in Marketplace Apps

How a Marketplace app tech team is achieving gender diversity

Hello! My name is Genevieve Blanch, and I'm the Marketing Manager at RefinedWiki, creators of apps to give teams the tools to customize Atlassian platforms. Currently, 44% of the tech team at Re...

534 views 3 19
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you