Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,735
Community Members
 
Community Events
168
Community Groups

Xray: "Test Coverage Report" displays only "Uncovered" status, how can i view the remaining status

* Created Test folders and added tests to the folders
* Created test plan and added test executions for the same plan and executed the tests
*But when clicked on the "test coverage" in the "test plan" or "test execution" - statement is displayed stating "No tests associated with this requirement"
And also when clicked on "Test Coverage Report"  - Only status uncovered is displayed .

Am m testing regression cases , how can i view all the status in the test coverage.

TestPlantestCoverage.pngTestExecutiontestCoverage.pngTestCoverageReport.png
                                   

 

1 answer

Hi @Vinoda Yaragatti 

Do you have the Test cases linked with Requirement?

If not, it is necessary that Requirements (Epic, Stories, etc.) be linked with Tests using the link type "is tested by/tests" and with the correct direction:

  • Requirements -> is tested by -> Test
  • Test -> tests -> Requirement 

If you don't have the link set up, this should be the problem.

If you need further help, please contact the Xray Support (http://xraysupport.xpand-it.com) so that we can request additional information and investigate further.

Kind regards,
Rogério Paiva [Xray Support Team]

Hello @Rogerio Paiva 

 

Test cases linked with Requirement even though it showing UNCOVERED can you please suggest??

Hi @MTV Narendra - Network 

Please double check that you are using the correct link type ("is tested by"/"tests") and also that you have the issue types correctly configured in the Project Setting / Xray Settings / Test Coverage:

testcover.png

Only the issue types configured here are recoverable will be covered by Xray reports and features.

If you have any additional questions, please contact Xray Support (http://Xraysupport.getXray.app); we would gladly assist you.

Thank you.

Kind regards,
Rogerio Paiva [Xray Support Team]

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events