Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,294,116
Community Members
 
Community Events
165
Community Groups

XRAY import feature file nullpointerexeption

Edited

Hello,

 

I'm trying to import a feature file into XRAY through the REST API as specified in the docs here:
https://docs.getxray.app/display/XRAY/Importing+Cucumber+Tests+-+REST

I have tried using Postman/curl/jenkins plugin to import a .feature file to our Jira instance but I always get 500 NPE.

Here's the error message I get:

https://pastebin.com/kankAhsH

the stacktrace was too long so I made a pastebin

here's the curl example:

curl -H "Content-Type: multipart/form-data" -u username:mypassword -F "file=xraytest.feature" https://myserver/rest/raven/1.0/import/feature?projectKey=XRDUMMY

 

I've tried all combinations of .feature files. Tagged with requirement, untagged, empty and copy pasted the examples from the docs. Even though I'm sure I shouldn't get such an exception even if something was incorrect.

 

Here's a picture showing I got the project key right.image.png

Here's a picture of a postman try.Screenshot_11.png

If anyone could help me out it'd be great.

 

Thanks

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Apps & Integrations

Marketplace Partner Spotlight: AppLiger

This month the spotlight is on AppLiger. We caught up with Pavel Pavlovsky, CEO and Product Manager, to learn how the company started and what fuels the team's creativity.    Atlassian:...

339 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you