Web Resource : Could not find a file in configured directories.

nisargmunjpara
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 17, 2018

Hi,

I am trying to install web resource using script runner in my jira-core instance. However I am getting an error saying 'You need to configure at least one alternate resource directory before using a web-resource, see the documentation' & 'Could not find <tt>jsfile.js</tt> in configured resource directories:'.

I created one file 'script.js' and put it under 'C:\Program Files\Atlassian\Application Data\JIRA\scripts' location. 

-> script.js contains only an alert statement : alert("click"); 

I have put this line 'JVM_REQUIRED_ARGS='-Dplugin.resource.directories=C:\Program Files\Atlassian\Application Data\JIRA\scripts' in setenv.sh file as suggested in web resource documentation. I restarted jira instance several times but this seems taking no effect. I am still getting the same error as mentioned above.

I have entered below details in web resource : 

Note : some note

Context : atl.general

Key : script-key

Resources : scripts/priority.js      

   also tried, priority.js

So how can I configure resource directory so my script file can be found?    

1 answer

0 votes
Dave November 1, 2019

Did you ever figure this out, Nisarg?

Musku Nagaraju November 4, 2019

I am getting same error, Can anyone help me on this?

wcypierre
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 11, 2021

Some of the things to check on

1. If you're using Windows, check on setenv.bat. If Linux/Unix then setenv.sh 

2. The JVM_REQUIRED_ARGS is already set in the default setenv, so you need to add add to the start/end of the existing JVM_REQUIRED_ARGS in the file instead of making a new one

 

From the above, I see that the path is a Windows path but the OP updated setenv.sh which is for Linux/Unix and it seems like he/she could be setting the JVM_REQUIRED_ARGS instead of adding the option to the existing JVM_REQUIRED_ARGS

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events