Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Web Resource : Could not find a file in configured directories.


I am trying to install web resource using script runner in my jira-core instance. However I am getting an error saying 'You need to configure at least one alternate resource directory before using a web-resource, see the documentation' & 'Could not find <tt>jsfile.js</tt> in configured resource directories:'.

I created one file 'script.js' and put it under 'C:\Program Files\Atlassian\Application Data\JIRA\scripts' location. 

-> script.js contains only an alert statement : alert("click"); 

I have put this line 'JVM_REQUIRED_ARGS='-Dplugin.resource.directories=C:\Program Files\Atlassian\Application Data\JIRA\scripts' in file as suggested in web resource documentation. I restarted jira instance several times but this seems taking no effect. I am still getting the same error as mentioned above.

I have entered below details in web resource : 

Note : some note

Context : atl.general

Key : script-key

Resources : scripts/priority.js      

   also tried, priority.js

So how can I configure resource directory so my script file can be found?    

1 answer

Did you ever figure this out, Nisarg?

I am getting same error, Can anyone help me on this?

Some of the things to check on

1. If you're using Windows, check on setenv.bat. If Linux/Unix then 

2. The JVM_REQUIRED_ARGS is already set in the default setenv, so you need to add add to the start/end of the existing JVM_REQUIRED_ARGS in the file instead of making a new one


From the above, I see that the path is a Windows path but the OP updated which is for Linux/Unix and it seems like he/she could be setting the JVM_REQUIRED_ARGS instead of adding the option to the existing JVM_REQUIRED_ARGS

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events