Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,367,539
Community Members
 
Community Events
168
Community Groups

Unable to delete a team in Tempo

Screenshot_2.png

The Delete Button shows no effect.

The Teams i want to delete are empty and unused. I tried it several browsers.

What can i do to delete a Tempo team?

7 answers

Any update? Is anyone from Tempo team actually checking on this? 

Jan Rising Star Jan 24, 2019

Hi - I just tested this in my QA environment. I was able to successfully delete a team. I had to remove the links to all projects and boards first, then it allowed me to delete. Have you removed linked projects and boards and still not able to delete?

Hi @Jan The issue is specific to certain teams. I can delete others just fine. The steps are the same as reported earlier:

 

I have a similar issue, except that I get a dialog box that reads:

"There are projects, boards and/or issues linked to this team"

"Projects/Boards (1)"

If you click on the "1" in Projects/Boards it takes you to the Tempo Team configuration.  There are no issues, boards, or projects associated with the team.

 

 

If i add an actual project or a board to this team - the number changes to 2. If i delete it, it changes back to one, while there are 0 boards or projects on the team configuration page. So I imagine that somehow some teams have an orphaned entry in the DB.

Jan Rising Star Jan 24, 2019

example.png

@Jan thanks, but as I mentioned there is nothing on Team configuration page. Please see screenshots of each step I take: 

 

1. Screenshot 2019-01-24 at 15.56.56.png

2.

 

Screenshot 2019-01-24 at 15.57.01.png

 

3. 

Screenshot 2019-01-24 at 15.57.08.png

Jan Rising Star Jan 24, 2019

@Mike Kondrashin Okay. I think our replies were overlapping.

@Susanne Götz _Tempo_Are you able to assist with this issue?

I've got the same problem. Can't delete the Team, as Tempo believes it is still used … which  is basically wrong …

 

If anybody has an idea where to start solving this, I'd be very glad.

I have a similar issue, except that I get a dialog box that reads:

"There are projects, boards and/or issues linked to this team"

"Projects/Boards (1)"

If you click on the "1" in Projects/Boards it takes you to the Tempo Team configuration.  There are no issues, boards, or projects associated with the team.

If you remove all the members in the team and remove all project or board links, then delete works. If not even on Jira 8.13 and tempo 15.0 delete button doesn't do anything. They could throw an error asking users to remove before deleting.

I also ran into the problem of not being able to delete
Please tell me how to delete in the database

done

SET FOREIGN_KEY_CHECKS = 0;

delete from AO_AEFED0_TEAM_V2 where id = xx;

SET FOREIGN_KEY_CHECKS = 1;

Hi all, 

It might be useful to create tickets for this problem in our Tempo support (https://tempo-io.atlassian.net/servicedesk/customer/portal/6) as in some cases, this might be caused by missing permissions or boards/ projects that were deleted before they were un-linked from the Team.

There is no "general" solution to this problem and there is a difference if you are using the Server or Cloud version.

Regards, 
Susanne Götz
Tempo team 

Like # people like this

Thank you

Regards,

Susanne

Any news here?  Seems to still be an issue in the newest version.

Thanks

Robb

Hi @Robb F. Watkins ,

As mentioned earlier, there is no general solution for this.

There was a bug that has been fixed some time ago, where Team links were not correctly removed when a Board/ Project was deleted. The fix prevents this problem to occur, but does not fix the problem for Board / Projects that were deleted before the fix was released.

In case you are using the Cloud version, the link has to be removed from your database by the Tempo development team. 

If you are using the Server version, you will need to check the ID of the Team you need to delete in your database (AO_AEFED0_TEAM_V2) and then check the Links that are listed for this team (AO_AEFED0_TEAM_LINK). If there are still links listed for the Team ( even if there are none shown in the UI) the links will need to be removed manually.

Regards,

Susanne 

Like # people like this

Thanks for this information! 

Same problem!

Same Problem

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events