It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sorry, my bot code is having an issue.

When I type "@jira DOPS-1234" in a team that has Jira Cloud installed, or just type "DOPS-1234" to the Jira Cloud personal chat, I get "Sorry, my bot code is having an issue." in response. It works for other Jira projects under the same account.

We did have a workflow step properties permission hack in the DOPS project (similar to this) set to deny cloning, but we've since removed that and this permissions view now works: https://MYCOMPANY.atlassian.net/rest/api/2/mypermissions?issueKey=DOPS-1234

The project has custom fields (like "cf[5678]" and "customfield_5678"), but I think the other projects that are working also have custom fields.

The project is not private. Everyone who has a Jira account in our organization can see the tickets.

I can bring up DOPS tickets successfully by using "@jira search issues", or by clicking the Jira Cloud button below the "start a new conversation" text box and using the search function there. And when I go to the Jira Cloud app, the "Assigned to me" tab does show me DOPS issues and I can interact with them. So it doesn't look like it's a complete block.

Any ideas for what might be wrong?

1 answer

1 accepted

1 vote
Answer accepted

Hello @Paul Nickerson,

Could you please try to use find command in a private conversation with bot or in the channel to bring up DOPS issues? (find DOPS)

Also, do you have any custom filters set up? Tabs like Assigned to me or Reported by me use default Jira filter, hence they display the issues properly. 

You might as well try to reinstall our add-on in case changes to workflow and permission schemes for this project happened recently. 

If you would have any other questions or comments, please feel free to lag a ticket at 

microsoftteamsintegrationssupport@softserveinc.com

Best regards,
SoftServe Support Team.

If I use the find command to find "DOPS-1234", I get "We didn't find any issues, try another keyword." in reply. If I type in the issue's summary, then it finds DOPS-1234 correctly. If I try to find a more generic word, it finds lots of issues, including several from the DOPS project. So find seems to work, if it's not intended to find by issue ID.

I have a lot of custom filters in Jira which I have saved. I had mentioned that the "Assigned to me" tab works just to show that the bot does have access to show DOPS issues.

Do you mean reinstall Microsoft Teams for Jira from the Atlassian Marketplace into our cloud Jira account? We did modify the permissions hack in the DOPS project recently, so yes, that would be worth a try. I'll ask an admin to try reinstalling it.

Dear @Paul Nickerson,

As for your questions, we've meant to reinstall Jira Cloud add-on in Microsoft Teams first.

As for finding an issue, Jira bot is not intended to find the issues by its ID and this is related to the situation when Project Key contains a number. In such a case, after reinstalling, you can try one more time to find it by mentioning bot in a chat (@Jira Cloud) and typing just an issue key you are looking for without "find" command since it's used for searching via description or as you've mentioned above, you can find it by typing in the issue's summary or just by more generic word. As for command 'find', it only looks for issues by keywords and not issue ID.

Best regards,
SoftServe Support Team

Thank you for the follow-up. I tried uninstalling the bot from the Team I manage, and then installed it into the Team again, but the problem persists. When I type "@Jira Cloud DOPS-1234" in a Channel, it still replies with "Sorry, my bot code is having an issue."

Dear @Paul Nickerson,

Could you please provide us with information about MS Teams, JIRA Cloud integration, and the current operating system versions?If you use the desktop version of MS Teams, please try to perform the same actions in the web version. Also please reinstall the MS Teams application and try to search for the issues in a team room with Jira Bot.

In addition to it, please make sure that you are searching for the issues of JIRA instance which is integrated to the current channel tab. 

Also please try to test other bot commands in the tab where the issue finding doesn't work and provide us with the screenshots. I mean create, edit, watch functions etc (type '@Jira Cloud help' to see the list of commands). Since we couldn't reproduce the same issue on our side that would help us to investigate whether it is a configuration issue or some kind of general bug.

Best regards,
SoftServe Support Team

I have tried "@jira DOPS-1234" in the Teams website on Chrome 72 and Firefox 65, and in the Teams app on Android 9, and got the same failure in each. I use Fedora 29 (Linux) as my OS, so there is no desktop Teams application that I can download and install.

When I uninstall and reinstall the Jira Cloud app bot in my Team, it does not ask me to re-enter my Jira URL (instance), but I remember that when I first did it I had entered https://MYCOMPANY.atlassian.net/, which is the only Jira URL I use. Also, I am able to bring up other issues from other MYCOMPANY projects by typing, for example, "@jira CAM-1234", so I know the Jira URL is working correctly.

Here are screenshots from testing I did in one channel of my Team:

jira-cloud-teams-1.pngjira-cloud-teams-2.pngjira-cloud-teams-3.pngjira-cloud-teams-4.png

Dear @Paul Nickerson

Thank you for the provided screenshots. It is very helpful.  As we can see you've tried to use other issues.
Could you please tell us, are you facing the same error when you try to find other issues in the same(DOPS) project?
Try to keep the same thread for Jira bot when you are working with the issue using "Reply".
Also, please send us screenshots from your personal chat.

Best regards,
SoftServe Support Team

Dear @Paul Nickerson

Could you please tell us, what specific setting DOPS has that delineates it from other projects.
Also it would be nice to know your Jira url (https://xxx.atlassian.net) and team user id: can be found in chat with bot in the url.

Best regards,
SoftServe Support Team

Yes, all DOPS issues have had the same error, and I've tried many.

I noticed that one of my screenshots does not show the whole conversation that I had when creating an issue. Below is a screenshot of a direct personal chat with the Jira Cloud app, where I create an issue. The responses are the same as when I used the bot in a shared channel above.

Interestingly, a new issue titled "Jira Cloud and Teams integrations test 2" did successfully show up in the DOPS project (and "Jira Cloud and Teams integrations test 1" also showed up). So while "create" ends with an error, it does still successfully create an issue.

I was clicking the response buttons that the bot presented to me (like "Task"), so I think I was staying in the same thread when needed. But I also just tried calling up two different tickets in the same shared-channel conversation, screenshotted below, and that still fails.

I think the DOPS project has a lot of customizations in Jira which differentiate it from my organization's other projects, so I'm not sure how to single out differences that might matter. Are there any differences in particular you're looking for?

Jira URL: https://cashstar.atlassian.net/

I think this is the Jira Cloud app ID: 11cd7f33-594f-4d45-aa2b-c801c2422ee5

The Jira Cloud chat About tab says it's version 1.3

jira-cloud-teams-5.png

jira-cloud-teams-6.png

I just found a difference that might matter. DOPS issues do not have any priority field. I notice that when I type, for example, "@Jira Cloud BEAR-634", the card it returns shows the issue's priority. But I don't think DOPS issues have any priority field whatsoever. It's not that the priority field is there but hidden and set to blank; the priority field has been removed from DOPS altogether. Could that cause this problem?

I've tried a bunch of Jira searches like "project = DevOps AND priority >= Trivial" and "project = DevOps AND priority is not EMPTY" and more searches like that, and I can't ever find any DOPS tickets. I think the priority fields simply does not exist on DOPS tickets.

I'm not an administrator of the DOPS project, but I can see some things in the project settings, and when I look at the Fields settings page, there are a lot of fields, but none of them are priority.

Does the Jira Cloud bot code gracefully handle grabbing an issue with no priority field?

jira-cloud-teams-7.png

Dear @Paul Nickerson,

We have just tested this, and apparently the problem is with the priority field. We get the same error message when trying to pull an issue from a project that has no associated priority field with screens. 

We will escalate this request to our development team, but it will take some time to investigate this case.

Is it possible for you to try and implement the field in your project?

Best regards,
SoftServe Support Team

Dear @Paul Nickerson,

We have deployed a fix. Please do feel free to test it and let us know in case there is anything else we can assist you with.

Best regards,
SoftServe Support Team

Like Paul Nickerson likes this

It works! Thank you so much for helping me out here and getting this fixed. I'm really glad to have this working.

I've tried it out in a public channel and a private chat, and both are working now.

I wasn't sure if we'd be able to put the priority field back into our project, since we've replaced it with a custom numerical priority field, so I'm glad you were able to deploy a fix.

I am all set now. Thank you again.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Marketplace Apps & Integrations

Join our Webinar: 5 use cases to supercharge Jira with apps

G’day Atlassian Community! We’re excited to announce that we’ll be doing a new webinar on 5 use cases to supercharge Jira Cloud. The Atlassian Marketplace offers customers thousands of apps and int...

108 views 1 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you