Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,271
Community Members
 
Community Events
168
Community Groups

My custom ACE app keeps loading and finally shows an error saying Something's gone wrong

Edited

Hello. I am new to Atlassian and am running into a problem using ACE and ngrok
Steps: 

1. Installed atlas-connect globally
2. Ran `atlas-connect new` and chose jira as the template, named the app as `test`
3. Ran `cd test`, `npm install`
4. I got an error saying Xcode version not detected which I solved by resetting path: https://stackoverflow.com/questions/60573595/npm-install-fails-on-node-gyp-rebuild-with-gyp-no-xcode-or-clt-version-detec
5. I renamed credentials.json.sample to credentials.json. I added the following information- 

{

"hosts": {

"https://<my-site>.atlassian.net": {

"product": "jira",

"username": "mahima@optimizory.com",

password": "<auth token from atlassian>"

}

}

}
6. I ran `ngrok authtoken <token from ngrok>`
7. Then I ran `npm start`

Results: Screenshot 2022-09-21 at 3.24.28 PM.pngScreenshot 2022-09-21 at 3.23.49 PM.pngScreenshot 2022-09-21 at 3.28.37 PM.png

1 answer

Given your error messages, it is most likely that the ngrok tunnel does not work.  As a first step, follow the ngrok links and try to get the tunnel working.

Without a working tunnel, Jira will just timeout.

Hello @marc -Collabello--Phase Locked- 
Thanks for replying.
I fixed the tunnel problem...I installed ngrok with brew previously, but I removed it and installed the npm package..but I am still getting loading spinner followed by error  in the app

Screenshot 2022-09-22 at 10.17.35 AM.png

here are the browser warnings:
Screenshot 2022-09-22 at 10.21.28 AM.png

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events