Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to avoid timeouts when running exportSpace using acli? Edited

We run a periodic task using acli that look like this:

acli.sh --action runFromCsv --common "--action exportSpace" --file "spaces_to_export.csv"

Lately it fails every time on one of the larger spaces (up to 300MB when zipped). Of course, the one that fails varies, and if I only run it on that space is completes just fine.

The failure message is:

Timeout waiting for long running task to show progress. Last response was 0% complete.

Adding the --connectionTimeout flag seems to make no difference.

 

Any ideas why this failure message would appear, when individual exportSpace actions work just fine?

 

Update

I managed to capture a failure in debug mode. Unfortunately, not much more information:

Run: --space "XXXX" --exportType "HTML" --file "/volume1/Backups/Confluence/exports/HTML-xxxx.zip" --action exportSpace


Waiting for task completion: 0% complete. 
.............................................................................................................................................................................................................................Client error: Timeout waiting for long running task to show progress. Last response was 0% complete.
com.appfire.atlassian.cli.Exceptions$ClientException: 1 actions failed, 8 actions were successful from file: /volume1/Backups/Confluence/spaces_to_export.csv
at com.appfire.cli.cli.objects.TrackingCounts.getRunActionCompletionMessage(TrackingCounts.java:142)
at com.appfire.cli.cli.helpers.RunHelper.runFromCsv(RunHelper.java:812)
at com.appfire.cli.cli.CliClient.handleRequest(CliClient.java:785)
at com.appfire.confluence.cli.ConfluenceClient.handleRequest(ConfluenceClient.java:770)
at com.appfire.cli.cli.CliClient.process(CliClient.java:657)
at com.appfire.cli.cli.CliClient.doWork(CliClient.java:536)
at com.appfire.atlassian.cli.Base.doWorkForName(Base.java:375)
at com.appfire.atlassian.cli.Base.process(Base.java:170)
at com.appfire.atlassian.cli.Base.handle(Base.java:84)
at com.appfire.atlassian.cli.Entry.main(Entry.java:27)

reset session

 

1 answer

Hi @liteyear ,

Please let us know whether you have added the --connectionTimeout 0 within the exportSpace action. 

Please find below action for your reference.

--action runFromCsv --file CLI.csv --common "--action exportSpace --exportType "PDF" --file @space@.zip --connectionTimeout 0"

If you are still facing the same issue, please check if you are able to export the spaces from the UI.

We have opened a support ticket, https://bobswift.atlassian.net/servicedesk/customer/portal/1/SUPPORT-6386 to better track your request. However, we couldn't add you as a reporter.  Please sign up using this link https://bobswift.atlassian.net/servicedesk/customer/portal/1/user/signup  and share the user name/id. We'll then add you as the reporter and confirm. 

 

Thanks,

Reshma

Hi Reshma,

 

Yes, I've tried several variations of the --connectionTimeout flag, including 0 and successively bigger numbers. It seems to make no difference.

 

Yes, there is no problem exporting using the UI.

 

Subsequent to my original post I ran it again with --debug in the --common section as well as outside it, to produce more detailed logging around the periodic progress check. As luck would have it, this time the whole process succeeded, so I still don't have the detail log of a failure! I'm sure it will fail again shortly, so I will share the log when I have it.

 

I believe I already have an account there. Please see attached screenshot.

Screen Shot 2021-03-31 at 9.59.00 am.png

Hi @liteyear ,

Thanks for your response!

We have added your account as the reporter to the support request https://bobswift.atlassian.net/servicedesk/customer/portal/1/SUPPORT-6386 and we will proceed the further communication through this support ticket.

As per your last response, the export action ran without any failure. Please confirm the same and make sure you have proper network connectivity when you run the action.

If you face any failure again, please provide us the complete debug logs along with the version of your confluence and the CLI client version.

Let us know if you have any questions.

Thanks,
Reshma

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
TAGS
Community showcase
Published in Marketplace Apps & Integrations

New Cloud Apps Roundup - Spring 2021

Atlassian's marketplace partners have had a very productive start to 2021! Since our last roundup, our developer community has added over 160 new cloud apps to the Atlassian Marketplace to help you...

202 views 3 19
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you