Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,367,297
Community Members
 
Community Events
168
Community Groups

Cloud API Authorization - Postman not working

Definitely new to this ...and struggling.

If I'm logged into my cloud account, can put the https://xxxx.atlassian.net/rest/api/2/search into the same browser and come up with the 50 or so issues.

Go to Postman, and getting 401 Unauthorized.  I'm using basic authentication, with my email that I log into jira along with API key I generated.  I've also tried to use email:apikey converted to base64 - that also gives me the 401 Unauthorized.

 

Postman ScreenShot.jpg

Can anyone let me know what step is missed here?

1 answer

0 votes
Hana Kučerová Community Leader Nov 28, 2021

Hi @Tim Barrow ,

I've checked my configuration and it is the same - Basic Auth: email + API token.

When I for example add one letter to the API token, I got the same error message, so are you 100% sure you've filled it up correctly? Sometimes spaces are added in the beginning or the end of the token and then the token is invalid.

Checked for additional spaces (used notepad++ to make sure there wasn't something extra added).  Showed the password and made sure it matched the API token that I generated.  Made sure that the email exactly matched what was on my site.

 

Unfortunately none of this worked.

Hana Kučerová Community Leader Dec 26, 2021

Hi @Tim Barrow ,

thank you, this is really strange, it should work.

Another idea - maybe you can try to create a new token?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events