Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,359,817
Community Members
 
Community Events
168
Community Groups

Workflow update not saving

I've  updated my individual Jira project workflow but I am getting an error message when I'm trying to save my changes

problem:

1. Made changes to my workflow

2. hit Update workflow 

3. a window pop up to ask which issue type you want  this workflow to be saved ( I choose 'Task' - then hit Next

4. new window pops up for review changes and asking.. Your project may contain issues in statuses you’re deleting. To prevent errors or unexpected behavior, tell us where we should move these issues.

4. I picked 'ToDo' from the drop-down (tried other options as well)

 5. hit save 

Result:  Error message 'We could not save your changes and spinner spin's forever on Save button.

1 answer

0 votes
Brant Schroeder Community Leader Aug 10, 2022

@Faisal Farooqi Welcome to the Atlassian community

Have you tried moving the issues out of the status prior to making the update to the workflow?  Then once all the issues in the status you are deleting have been moved try the update again.  

@Brant Schroeder Thank you for the quick response. 

Unfortunately, I did not move the issues statuses prior to update my workflow and directly delete the statuses  itself.

Are you saying I've to  discard my updates and Redo from scratch?

Brant Schroeder Community Leader Aug 11, 2022

@Faisal Farooqi If the update worked then everything should be fine.  In your initial question you made it sound like the update did not occur and the workflow change was timing out.  If you were unable to make the change I was suggesting that you change the issues that had the status you were removing from the workflow before you made the workflow change.

Thank you Brant, I had to change the statuses of those prior to update the workflow.

Brant Schroeder Community Leader Aug 19, 2022

Great, glad this resolved your issue.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
TAGS

Atlassian Community Events