Null Pointer in Workflow Validator

Hi All, 

I am getting a null pointer when transitioning an issue from one workflow state to the next.  The next state has a validator that is "Only users with Resolve Issues permission can execute this transition."  This user does not have those permissions.

The null pointer DOES prevent the transition, but I am expecting more information for the user such as "You don't have permissions" rather than a null pointer.  Is this a bug or working as intended?

Thanks!

image2015-5-19 14:59:47.png

2 answers

1 accepted

This widget could not be displayed.

Depends! Do you have any workflow validators in the "Pass" transition? If so, that is a good place to start debugging. You will have to check the logs to find the issue without doubt.

Since you are on Atlassian Cloud, raise a support ticket with Atlassian to get the logs.

This widget could not be displayed.

Thanks Jobin.  The Pass had the same validator which also failed in the same way.  I decided to go with a conditional rather than a validator, and that works for my needs.

Thanks for the response.  Consider it accepted.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

201 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you