I can't find Accept remote API calls settings in our jira

Hi JIRA help,

I'm trying to find how to enable API calls with JIRA for my team ( I'm currently working on one cool plugin ) and I need to test it with API's , but I can't find in our JIRA . Can you please help me?

Curl request returning 'HTTP/1.1 400 Bad Request' but I'm following instructions from JIRA Dev but no luck 

 

Thank you,

Natalie

8 answers

1 accepted

0 vote

It's not a setting you can change on Cloud, but it is switched on.

What instructions do you have for testing the connection?

Using this doc:My curl command is looking like  :

 curl -D- -u myAccount:myPassword -X POST --data filenameWithJson -H "Content-Type: application/json" myJira/rest/api/2/issue/

Respond is:

HTTP/1.1 400 Bad Request
Server: nginx
Date: Mon, 31 Aug 2015 22:08:34 GMT
Content-Type: application/json;charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive

Basically I'm trying to send a request with python to create an issue.

 

But I was checking is it working, that's why running curl command.

The url is missing the protocol and issue key

hi, have you solved this problem?   I can't find "Accept remote API calls" setting in JIRA 7.1, either.

Please see the previous answer.

 

According to this comment, the option is removed as per the removal of the SOAP API.

Hi Natalia,

First login with credentials which have full admin rights.

Then go to setting->system in System info section you'll find "Accept remote API calls"  which is by default OFF so change it according to your need.

Regards,
Sopan Sagorkar 

0 vote

That's incorrect - Natalia is using Cloud, so she has no access to that, and it's already enabled.

@Nic Brough [Adaptavist] @Sopan Sagorkar can't find "Accept remote API calls" at "System info" in JIRA 7(server version, not cloud). Can you help find it?

0 vote

Admin -> General configuration

nope

May be in 7 it call REST API?

Atlassian REST API Browser - 3.0.12
Plugin byAtlassian
Disabled
0 vote

No.  That's an add on.

Oh, hang on, you're on 7.  The flag has been removed from the general configuration.  I guess because parts of JIRA 7 require it to be on, so it's now always on.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

190 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you