Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

How do I clear/de-select a date in custom date field?

In old JIRA on the cloud, when I would edit a date I had the ability to wipe out the selected value, click on the check mark and the field would be reset back to NULL/EMPTY.


How do I do this in NEW JIRA?

2 answers

1 accepted

3 votes
Answer accepted

Hello Rob,

Thank you for getting in touch with Atlassian Community!
I've tested here and I was able to remove the date by clicking and pressing delete on the keyboard.

Screen Recording 2019-02-11 at 05.00 PM.gif

Please, give it a try and let us know how it goes.


Which Browser were you using when you did this? It did not work for me.

Hi Naomi,

I was using Google Chrome. 


Hey @Angélica Luz, unfortunately this seems not to work with the new UI. Neither using BACKSPACE nor DELETE does clear the field. Please can you revisit this issue?

Hi Büro,

I tested today using Chrome and the only difference is that I had to press delete/backspace/return (it will depend on the keyboard) and then click out of the field, the same as Brandon mentioned here on this thread. 


Like Liza Furr likes this

Hi Nathan,

Thank you for sharing the bug.
I talked to the support engineer that helped you on the ticket and we tested again, but it didn't work, so something changed since the last time I tested that was 8 days ago.


Kathy Hart Community Leader Sep 26, 2019

I am in Windows 10 on Google Chrome, new view I cannot delete a date without switching to the old view. The solution above does not work for me. I have attempted multiple times. 

We´re using Chrome, and no button (delete/backspace/return) works. Please solve the problem in the new Version.

I tried this yesterday and it was fixed for me in my Jira Cloud instance

There is no post since three years, but within the new ui on Windows 10 (Edge) i had problems setting a custom Date field back to null.

The tips above did not work for me.

What currently works for me:

select the date field and click on the small x right to the date and click somewhere elseJira - set custom Date field back to null.png


Addendum: If I do get an error at first, I just refresh the browser and do it again. Then it works

I am able to remove the date by pressing my backspace key (Not delete) and then clicking out of the date field,

Kathy Hart Community Leader Sep 26, 2019

This apparently worked, but I couldn't see that it had worked until I clicked away. The fact that you still see the date in the field after you hit backspace makes you think it didn't work. 

Clicking backspace will get it cleared, but then it can't save the field.  Still broken!

Like Gary Pezza likes this

Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you