Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How do I change UI language in JIRA?

Today Jira started showing up in Swedish.

Jira settings shows a greyed out box with Swedish selected as my current language, and shows a link to my Atlassian account settings page, prompting me to change language there instead.

So I went there, and made sure it's in English. Saved, logged out, logged back in.

Still, it's in Swedish.

How do we get English GUI?

4 answers

1 accepted

2 votes
Answer accepted

After I solved it this way, my colleagues started having the same issue.

We tried my solution above with varying results.
Without having an exact solution we always managed to solve it by wiggling the system enough by changing from and back to English a few times, and logging out and back in.

Sometimes the switch took a couple of minutes. Without doing a change, a simple page refresh finally reflected the change.

We've all solved it, it's just not a clear cut behavior/solution.

Managed to solve it after about 5-6 switches of the language :)
There is clearly an issue there, but works after a few tries.

Like # people like this

Ok we solved it, it was really silly.

The options page you're linked to, it said English (US).
If you click on that and reselect English again, it forces a save.
After the save, problem went away.

Doing it several times, and logout, on the end.... IT WORKS....Pffffff.

BUT Thanks for the answers, I can finally move on.

It does not solve in my case. I have selected English as language but it keep showing to German.

 

Its really annoying, please help.

I can confirm we had a similar problem with a Service Desk project defaulting to Czech language.

We changed the Jira Settings default language to English US then back to English UK and created another new project and all was back to normal displaying in English UK!

Bizarre!

It was too simple a solution we dismissed it originally so thank you for this post :-)

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you