Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,295,601
Community Members
 
Community Events
165
Community Groups

Getting error please select an epic for creating subtask

Hi All,

 

I am trying to create a subtask in jira story.

For this i am trying to add field configuration, where i found epic link is locked. Even if I removed from screen, I am not able to remove from field configuration. This results in error in creating subtask. I am getting error as please select an epic even if there is no field for selecting epic on the screen. I want sub task to be created under story not an epic. So want to remove epic link from field configuration. Can someone help?

1 answer

1 accepted

1 vote
Answer accepted

Forget the field configuration, it is not the problem here.

The code for Epic link looks at the issue type and the field itself, but it is not mandatory anywhere (you can't put it on Epics or sub-task types).  I suspect your error is being driven by something else.

Could you give us the exact text of the error?

please see the screenshot above. Mine is company managed project. We had hierarchy as epic-> story. Now I want to add  task/subtask under user story. For this I copied Issue type scheme of story itself to create issue type scheme for task. Then I tried to edit field configuration to remove all the unwanted fields while creating tasks e.g. epic name/epic link. I could remove  them from screen. But for field configuration it shows required. Don't understand how to resolve it. I don't want all these fields mandatory for subtask creation.

Epic link is not a required field.

Your error message looks like it is being generated by a validator in your workflow - when Jira's mandatory field flag is set, the error message is not "please set <field>", and it uses the exact name of the field.  Your list of fields does not have "Epic" in it, so the message is not coming from the mandatory field setting.

You'll need to edit your workflow.

@Nic Brough _Adaptavist_  thanks for your reply. Please find my workflow above which I am using for task. As per my understanding this is something which will be used after I create it to navigate statuses. However, I have a problem before creating it.  Below is my task screen which has only 4 fields which I want for task.

but still I getting error on the screen to select epic. I dont know what to change to remove that error. Could you please help.

Screenshot 2022-06-07 at 11.52.42.png

there are no validations in my workflow. tried to assign a simple workflow as well which has just 3 stages transition of states. That also didn't work. 

I'm sorry, but that message really is coming from a validator.  Are the sub-tasks using a different workflow to the issues?

@Nic Brough _Adaptavist_ thanks a lot. I didn't know much about validators in workflow. I checked it now. Created a different workflow for subtask. Its working now. thanks so much.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
PERMISSIONS LEVEL
Site Admin
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you